Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

enter image description hereenter image description hereI used to be able to share my network connection by editing the Auto Eth0 to share with other computers in the Ipv4 section and now I upgraded my laptop to 11.10 .

Now are there no wired connections in the network manager. When I click my connections applet at the top of the tray it also says wired device not managed!

when I type ifconfig -a

daniella@daniella-1001HA:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 90:e6:ba:83:d6:fc  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:45 

eth0:avahi Link encap:Ethernet  HWaddr 90:e6:ba:83:d6:fc  
          inet addr:169.254.13.40  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:45 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:25:d3:90:43:41  
          inet addr:192.168.0.6  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::225:d3ff:fe90:4341/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12881 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12867 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8851081 (8.8 MB)  TX bytes:2343199 (2.3 MB)
share|improve this question

10 Answers 10

up vote 93 down vote accepted

wired device not managed

Most probably your interface appears in /etc/network/interfaces. By default, NetworkManager does not manage interfaces that appear in /etc/network/interfaces. You can change this behaviour.

To do this - in a terminal:

sudo nano /etc/NetworkManager/NetworkManager.conf

change the line managed=false to managed=true

Save, stop and start network manager:

sudo service network-manager restart

Alternatively, you can remove the interface from /etc/network/interfaces.

backup the current interfaces file:

sudo cp /etc/network/interfaces /etc/network_interfaces_backup

Then open the file:

sudo nano /etc/network/interfaces

Delete everything in that file and copy and paste the following:

auto lo
iface lo inet loopback

Save, stop and start network manager:

sudo service network-manager restart

enter image description here

Double check in network manager (click on the indicator) that you have Enabled Networking ticked and you should also force deletion of old "wired connections" and selecting the new wired connection shown in the network manager indicator.

share|improve this answer
1  
Glad to hear it's working. But you also might check out wicd if you have more network troubles. It's in the repo, but you prolly need to do sudo service network-manager stop for wicd to work properly –  Matt Oct 24 '11 at 5:29
    
I like the "alternative" method better because it allows you to later edit the network connection from network manager's UI, to specify additional nameservers, DHCP client ID, and 802.1x security settings, etc... –  Simón May 23 at 23:56

wired device not managed

I had the same problem with a fresh install on my Asus Eee PC 1005HA. The live environment worked with no problems, but once installed I couldn't get the connection to respond or to not read "device not managed". When I changed the text in this configuration file and restarted Network Manager everything worked!

gksudo gedit /etc/NetworkManager/NetworkManager.conf

for lubuntu:

gksudo leafpad /etc/NetworkManager/NetworkManager.conf

Now the text editor will open. Find the line managed=false and replace false with true and save the file (ctrl+s) and close the file.

Restart your computer or the NetworkManager service (sudo service network-manager restart).

share|improve this answer

wireless device not managed

I've also found this issue after installing the Ubuntu 11.10 alternate version.

In my case, the /etc/network/interfaces was configured during installation to download new packages, and the conflict arose after the NetworkManager was set up during the first session.

The solution I've found was commenting the lines related to the wlan interface in the /etc/network/interfaces (in console, sudo vim /etc/network/interfaces or your editor of choice):

# The primary network interface
#auto wlan0
#iface wlan0 inet dhcp
#    wpa-ssid [your_ssid]
#    wpa-psk [your_wpa_password]

And then, as Joseph VanPelt proposed, set managed=false in the /etc/NetworkManager/NetworkManager.conf and running sudo service network-manager restart.

share|improve this answer
    
Excellent! This worked for me on an Eee PC 701. –  oKtosiTe Dec 10 '11 at 17:00
1  
Setting managed= is unnecessary (unless it's meant to revert a prior change). –  Mathieu Trudel-Lapierre Apr 13 '12 at 17:42
    
For me, setting managed=true is what solved it eventually. It did not work with managed=false. –  Daniel Hershcovich Jun 29 '12 at 18:51

Situation like this may appear, when one runs pppoeconf or something similar and the command overwrites the setting saved by NetworkManager. Even though the device seems to be working properly, Network Manager shows device status to be unmanaged.

If this a normal user's pc with simple network configuration like connecting via DHCP and automatic configuration, simply out comment the lines and restart network manager.

$ sudo restart network-manager

If situations other than these, please explain.

share|improve this answer

wired device not managed

This is a simple command which does the same as the accepted answer non-interactively.

Run this command in a Terminal to use it:

sudo sed -i 's/^managed=false/managed=true/' /etc/NetworkManager/NetworkManager.conf

You may have to restart the network manager afterwards with this command:

sudo service network-manager restart
share|improve this answer

I had the same problem, I solved it by commenting the lines where the unmanaged device was mentioned, by mac address, in /etc/NetworkManager/NetworkManager.conf.

[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false

[keyfile]
unmanaged-devices=mac:00:26:2d:fd:5c:e0

changed to

[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false

\#[keyfile]

\#unmanaged-devices=mac:00:26:2d:fd:5c:e0
share|improve this answer

In 11.10 you can go to System Settings and you should see a Network Icon. Run that utility and you should see tabs for your network devices, wired and wireless. Each tab has a slider that allows you to switch the device off. Or in your case switch eth0 or wired connection 1, as it is now called, on. May be. At least check that it not switched to off.

regards.

share|improve this answer
    
sorry but its a no go, there is no slider. I suggest you look at my screenshot. no slider there and I repeat there is nothing in the wired connections tab in my network manager. :( –  Daniella Glover Oct 23 '11 at 21:59

There are two ways to manage network connections. You either have to do everything thru the network manager and remove everything Except the Loopback entry in /etc/network/interfaces

auto lo

iface lo inet loopback

or totally remove the network manager thru the package manager or terminal and use the /etc/network/interfaces and /etc/resolve.conf file to control your connections. If not you will see the error you are getting. Even with static IP I've found that the network manager makes things easy and you can configure your IPV4 connections thru the menu.

share|improve this answer
    
please put all of that answer into a newbie answer and I dont get any of it :( I just want it to work nothing works! –  Daniella Glover Oct 23 '11 at 22:59
    
there is no Auto eth0 in the menu its blank! how can I edit anything if it isnt there! I need a useful answer! –  Daniella Glover Oct 23 '11 at 23:01

wireless device not managed

This is because the alternate images were for a period of time, configuring the wireless networks in /etc/network/interfaces; which causes NetworkManager to, on purpose, ignore the interface and consider them online.

A good solution if you want to simply use your wireless connection (or wired) with DHCP is to comment out these settings in /etc/network/interfaces for all interfaces except lo, and reboot your system or restart NetworkManager like so:

sudo restart network-manager

Of course, this means you will need to enter your wireless settings into NetworkManager (password, etc) after clicking on the right item from the applet menu.

share|improve this answer

Just to add a non-default answer, this can also happen if your computer has a hardware ON/OFF switch for the Wi-Fi interface. If you have such a "killswitch", ensure that you haven't accidentally turned the interface off

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.