Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm kinda new to ubuntu, and I have an HP Envy 14-2020nr. The computer has hybrid graphics, and since Ubuntu doesn't yet handle them very well I've been using vga_switcheroo to disable the discrete graphics card (AMD Radeon HD 6600M Series) at boot. Anyways with the discrete graphics card disabled if i suspend my computer, when i wake it back up the computer's fan goes to maximum and won't stop until I restart.

How can I go about fixing this so I can use the suspend without having to restart afterwards? I have tried turning back on the discrete graphics card before suspending and that seems to work. So is there a way to get my computer to turn it on before suspending, but then turning it back off when it resumes? Any ways at solving this would be much appreciated. Thanks.

share|improve this question
    
Anyone? I really need someway of either automatically turning on discrete graphics before suspending, or some other way of getting suspending to work. –  syst3mfailur3 Oct 26 '11 at 0:57
    
probably include the "echo ON ..." in one of the scripts for suspending etc., I do not know which ones would be best. For example, I use a script in /etc/rc6.d/ and /etc/rc0.d/ to turn the card on for shutdown/logout etc. Have a read through this: asusm51ta-with-linux.blogspot.com –  marto Oct 26 '11 at 1:41
    
+1 for "How do I stop my fans from going crazy...". are you a rock star? –  Eliran Malka Oct 23 '12 at 7:06

3 Answers 3

You can have scripts or commands run automatically before and after suspending. Just create a script in /etc/pm/sleep.d/. It should be named without an extension, like 75ati_toggle. The Arch Linux Wiki has some shows the general convention for naming the scripts (link here). Anyway, the contents of the script could be something like this:

#!/bin/bash
# Script to disable and enable the discrete graphics card before suspend and after resume

case "${1}" in
suspend)
  # Commands to enable the graphics card before suspend goes here
  ;;
resume)
  # Commands to disable the graphics card after resume goes here
  ;;
esac

Hope this helps!

share|improve this answer

You can also turn it ON and then OFF after waking up.

This is a known bug reported to Ubuntu on launchpad here.

It was reported as well to the Linux kernel at the following link.

share|improve this answer

I had a similar problem in a Toshiba A350-22E and what I did was: boot up suspend wake up

simple as that. Then everything worked normal... I hope it helps you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.