Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I changed to gnome classic fallback, I auto-login but it defaults to unity 3d, how do I make auto-login default to gnome classic?

share|improve this question
Related to this question but we need an answer for the classic mode. – Jorge Castro Oct 23 '11 at 19:30

3 Answers 3

up vote 2 down vote accepted

auto log-in gnome classic desktop :

  • sudo apt-get install gnome-session-fallback
  • sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-classic
share|improve this answer

Run the following in a gome-terminal:

  • If you want GNOME Classic with effects:

    sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-classic

  • If you want GNOME Classic without effects:

    sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-fallback

share|improve this answer
gnome-fallback is perfect and what I need for my remote instance since screen updates aren't sent 100% during animations / screen redraws. But I don't think this setting is getting set correctly as Libre Office is still doing silly window resizing when multiple are open and I click its launcher icon. How can I verify this command has been sent correctly and is sticking? – advocate Feb 27 '14 at 4:59

For Ubuntu 14.04

I followed the post here

Summary :

  • Install the lightdm-webkit-greeter package: sudo apt-get install lightdm-webkit-greeter -y.
  • Open the /etc/lightdm/lightdm-webkit-greeter.conf file in your favorite text editor.
  • Add the following lines to the end of the file:
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.