Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I play a movie on my TV through HDMI, I hear periodic short static sounds. This happens with all players in Ubuntu, so this is not a problem with the player. When I play a movie through HDMI in Windows the audio is fine, so this is not a hardware problem. I managed to set VLC to using ALSA from its preferences dialog, and I know that for sure because my volume control icon became disabled. But VLC's audio was working great, static sounds were gone, and additionally some audio sync issues I had with VLC were gone when using ALSA.

So are those problems all connected to pulseaudio, and how can I force VLC not to use it and use ALSA instead?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It turns out pulseaudio can indeed be suspended with the pasuspender command, which is included by default in Ubuntu. That fixed the problem with the static sounds so pulseaudio was the culprit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.