Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a home directory mounted from a file server (OpenFiler software), with an entry in the file /etc/fstab It worked well with Ubuntu 10.04, 10.10, and 11.04 The line in the /etc/fstab file is similar to this:

192.168.0.100:/mnt/vg1/v1/users/user1 /home/user1 nfs rw,hard,intr 0 0

(I follow guidelines from here: https://help.ubuntu.com/community/SettingUpNFSHowTo )

After upgrading to 11.10, when trying to login, it returns me back to the login screen.

If I remove the entry in the fstab file, and therefore use a local home directory for that user, login works fine.

There are some other reports that suggest deleting the .Xauthority file. I tried that and it didn't help.

I thought some files may be causing trouble, so I deleted all the .* files except for some that are obviously application specific (.dropbox, .mozilla, .thunderbird, etc). Then I copied the four files that Ubuntu places in the home directory of a new user.

Any suggestion ?

share|improve this question

closed as off topic by bodhi.zazen, Bruno Pereira Feb 25 '12 at 1:39

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. –  Bruno Pereira Feb 25 '12 at 1:39

2 Answers 2

I have just upgraded to 11.10 and had the same problem (my home used NIS & NFS). In my case, I had to change the permission of my home directory from 700 to 711 adding x permissions. I hope there is a more fundamental solution since I do not want to add those permissions to my private home.

share|improve this answer

I had the same problem and found the fix in a bug report... the gist of it is that you have to disable some apparmor profiles that do not play well with nfs. I ran these three commands and it fixed the problem for me, but I still have to run them each time I reboot (CTRL+ALT+F1, log into tty1, issue commands, CTRL+ALT+F7, everything works)

here are the commands:

sudo apparmor_parser -R /etc/apparmor.d/usr.lib.telepathy
sudo apparmor_parser -R /etc/apparmor.d/usr.bin.evince
sudo apparmor_parser -R /etc/apparmor.d/lightdm-guest-session

it's just a workaround, hopefully the bug is fixed soon.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.