Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Gnome shell 3.2 and a gnome 3.2 theme installed. But when I use the search bar in Activities, gnome shell freezes and I am left with no other option except to restart the system. Is this a bug? Or is there any solution for this?

share|improve this question

closed as off topic by James May 22 '12 at 18:42

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

NOTE for new views: Apparently this was fixed with the last release of gnome-shell, because I can now use a non-default theme and search. So, hooray to the Gnome community! – b. e. hollenbeck Mar 18 '12 at 14:24
This question should instead be filed as a bug report, thanks! Instructions here. – Jorge Castro Apr 26 '12 at 2:42

I know this isn't a fix (I too have issues with the shell freezing, but not on the search iteself), but you can do the following to restart the shell:

Alt+F2, type 'r' and press return. Even if the alt+f2 dialog doesn't show, it will still take your command and run it. This restarts the shell but doesn't log you out or anything.

share|improve this answer
cool. I haven't tried that, since the dialog won't show up. Sounds to be a good idea. I will try it next time. +1 for the answer. – Vivek Oct 23 '11 at 15:03
I have the same problem - I can't figure out exactly where to report the bug. When I go to type into the search field in 3.2.0 (on 11.10), the shell crashes, and I'm forced to restart the shell. Incredibly annoying. I may have to attach a tty to the shell and see what happens. – b. e. hollenbeck Oct 25 '11 at 18:30
@blackn1ght: I tried it. But it did not work for me. I had to reboot or restart gdm from tty. – Vivek Oct 31 '11 at 6:38
same problem here with gnome-shell 3.2 activities opened/activated while typing. the fans kick in, temperature rises and only a hard-reboot works! – v2r Feb 25 '12 at 13:08

this is happening to me and i dont have a solution to prevent it but here is a way to get out of it without restarting gdm:

  • press CTRL-ALT-F1
  • this brings up a terminal
  • login
  • type in "ps -f | grep -i gnome shell"
  • take the process id PID rom that command type "kill -9 PID" where PID is your process id (like 6949)
  • gnome-shell will re-spawn at this point
  • press CTRL-ALT-F7 to return to the gui

This allows you to save any work. and not lose any windows when the lockup occurs.

Its possible to combine the ps and kill into one elegant command. Someone else can do that....I'm looking for a solution to the search issue.

MORE INFO: This happens to me 100% when I search. The solution I found was to change the shell theme to default Ubuntu GNOME 3 using the gnome-tweak-tool. This fixed me up. Seems like certain themes have compatibility issues.

share|improve this answer

There is probably not an easy solution, you would have to file a bug report upstream with gnome for any type of resolution.

FWIW I filed a similar bug report with gnome a few months ago now (was using Fedora 15 at the time).

In my experience :

  1. As advised, the default theme, including default icon set, works best. If you make customizations you are at higher risk for problems.

  2. There is some variability with the driver you use. Personally I use Nvidia. With the nouveau driver I got hard lockups and the only way to recover was with a hard reboot. With the nvidia driver, I did not get lockups but lost my icons.

I also had lockups when using the search, often I could recover by restarting gnome-shell (Alt + F2 , hit the r then Enter - you may not see any output on the screen during that sequence of keyboard activity ), or restarting X (did not have to hard boot with a lock up when searching).

When this (lockups) happens, you will need to ssh in from another box and pull the logs (for bug reports).

FWIW, here is an example of the kind of information you will be asked (probably from upstream)

I know it is old and from fedora, but, that is the sort of thing you are looking at and I can tell you from personal experience what the gnome developers will expect.

FWIW, the bug report I filed with gnome.bugzilla was unresolved and is so old that it no longer exists (I searched).

At the end of the day, it was easier to upgrade the nvidia card.

share|improve this answer

revert the theme into the original theme or download theme that is compatible with gnome shell version that you have.

share|improve this answer
I have the compatible theme installed, but still the search is not working. – Vivek Oct 31 '11 at 6:37
This is a gnome-shell issue, not a theme issue. I reverted to the default theme and it still doesn't work. – b. e. hollenbeck Nov 10 '11 at 19:08

To recover, probably a cleaner way is to terminal via ctrl+alt+f1 and then restart lightdm.

sudo service lightdm stop
sudo service lightdm start
share|improve this answer

this is a known problem. you can temporarily remove nautilus-pastebin plugin, until the upstream patch makes it into Ubuntu.

for more details, see the upstream bug.

share|improve this answer

may be this can help you..
it works for me..

Clear out the recently-used list:

echo "" > ~/.local/share/recently-used.xbel

then set the immutable bit to prevent all changes to the file (even by root)

sudo chattr +i ~/.local/share/recently-used.xbel
share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Apr 9 '12 at 10:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.