Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu 11.10 destroyed my desktop after running compiz manager and pressing on plugins menu. After pressing, the harddrive was working a lot (at least 5 to 10 minutes). After this, my sidebar disappeared and only a menu of the file manager was displayed. I could not reset unity by using unity --reset, because it stopped at a point.

I had to reinstall the whole system. System update by using live cd didn't solved the problem (desktop was still destroyed after this installation), therefore i had to remove the old system and to reinstall the whole system again. This is the second time that compiz manager destroyed my desktop. In ubuntu 11.04 i had the same problem for months ago.

My hardware is as follows:

Intel® Core™2 Duo CPU E8400 @ 3.00GHz × 2 motherboard P5K-E Wifi 8 GB RAM Ubuntu 11.10 x86_64

How can i avoid this problem in the future? Exist there an known bug with this hardware?

share|improve this question

closed as off topic by Marco Ceppi Feb 6 '12 at 20:43

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 6 '12 at 18:20

4 Answers 4

No need to format your hard drive.

What happens (and this happens in my case too) is that when you go to Preferences menu or Plugins List in the CompizConfig Manager (ccsm), it waits couple of secs and then starts resetting all the values to some default ones: this includes unchecking the Unity plugin as well (this is why you do not see the panel anymore, and reinstalling from the CD does not help -- you just have in your preferences not to use the panel).

Two ways to resolve the problem:

1) My way: I have exported Compiz settings from 11.04. Now, in 11.10 I install ccsm and go to Preferences menu, then I wait couple seconds before it starts ruining the system and then several minutes more till it ends torturing my hard drive, and the panel dissappears. You can even start ccsm from the terminal and see the values being resetting at the moment: the zoom plugin is the last one.

After that I just import my profile, and here you go! Alternatively (if you do not have a profile to import from), you may click Back in the CompizConfig Manager and manually select the Unity plugin back and all other plugins you like.

Be careful with importing the old profile: some of the values have changed, and some plugins do not work as expected anymore. So, I would suggest keeping stuff like keys associated with different commands etc. in the profile being imported and remove other options.

A good thing about this method is that after that opening the CompizConfig manager does not hurt anymore.

2) Another method is just to delete ~/.gconf folder and reboot, but I do not like or suggest doing this for obvious reasons. One is that this folder contains many more settings than just those corrupted by the CompizConfig Manager, another reason is that you still cannot use ccsm.

share|improve this answer

I use very intensiv blender (3D graphic tool). It works very well on ubuntu 11.10 x86_64 and the memory management is excellent. But now i have to disable alt-left mouse button (alt-LMB), because this shortcut is used very intensiv in blender and doesn't work because ubuntu reserved it. In the net i read that i have to use the compiz-manager to disable it. I will never use this tool because this is my production system and i don't want a new crash. Exists there a possibility to edit one flat file to disable this shortcut?

share|improve this answer

For what it's worth, I filed a bug against the fact that Compiz's "defaults" include turning off Unity, which Vadim mentioned: http://pad.lv/883108

share|improve this answer

This should no longer be an issue in 11.10, was fixed in compizconfig-python (0.9.5.94-0ubuntu3), bug report https://bugs.launchpad.net/compiz-compizconfig-gconf/+bug/874799

There are by default 2 profiles available, "unity" & "Default". The "Default" profile does not have the unityshell plugin enabled & a few other differences, it is used for the 'Classic' session. The "unity" profile obviously should be used when in the ubuntu session (unity-3d)

Previous to the fix, when clicking on Preferences in ccsm you'd be immediately switched to the "Default" profile & lose unity, ect.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.