Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 11.10 the nautilus version has a new feature, as you can see: it adapts the column's width to the content of the column itself (at least for the Name column).

This behavior is not always desirable, so I am looking for a way to disable it.

share|improve this question
1  
I have tried to do this with nautilus, but have only succeeded with thunar -in that file manager you can manually define your column widths in list view, then go to view > configure columns > and uncheck 'automatically expand columns as needed'. –  user76204 Jul 17 '12 at 17:04
    
I'd be interested in an answer for this as well. Please mind my bounty of 50 reputation! –  con-f-use Aug 22 '12 at 13:27
    
+1 if this could be solved for 12.04 as well! Someone inclined to open a bug/feature-request for the Nautilus devs? –  isync Jan 4 '13 at 0:08
add comment

3 Answers

As Roland Taylor said, the way Nautilus handles columns is at present not easily tweakable without writing some additional code and patching the application, which would not be trivial to do because of the way column handling is built in to Nautilus. There really is no way to do it in Nautilus by altering any configuration settings.

However, I was encouraged by con-f-use to give an answer relating to Thunar, the lightweight Xfce file manager. In Thunar it is very easy to set the widths of the columns in list view and they stay fixed until you feel the need to alter them. All you need to do is go to view > configure columns and uncheck the setting to 'automatically expand columns as needed'.

The screenshot displays the column setting and behind it you can see the adjusted columns in list view- any changes made to them are saved when exiting Thunar, unlike in Nautilus.

Future versions of Nautilus will probably adopt this feature (Ronald Taylor points out that it may be available in Nautilus 3.6 in Ubuntu 12.10), but for now this Thunar solution is unfortunately the only solution for people who want fixed columns.

enter image description here

share|improve this answer
add comment

As this seems to be hard-coded into Nautilus, your best bet be to report a bug, as there is no solution short of patching Nautilus. Even with the newer versions of Nautilus that use dconf, there is no option to change this setting:

Proof

12.10

In Ubuntu 12.10 (so far) it seems Nautilus no longer has this problem. If the final version comes with the standard Nautilus 3.6, you will be able to change the column width freely.

share|improve this answer
add comment

As i only have installed the German version, some translations of the menu might be different, but anyhow it will work if you enter the values below.

Configure fixed column-width

  1. open Terminal

  2. type in gconf-editor /apps/nautilus/list_view

  3. [right mouseclick] -> create / make key

  4. at name type in: all_columns_have_same_width

    type: boolean

    value: true

  5. close the editor. et voilà

Or, simply, execute gconftool-2 --type boolean --set /apps/nautilus/list_view/all_columns_have_same_width true in Terminal

The column width will stay now the same in nautilus, no matter of the length of the file name. Also after closing and re-opening, all columns will have the same size.

Good alternatives to the nautilus commander are: "Krusader", "Tux-Commander" and for whom who is missing Norton Commander : "GNOME Commander".

(For a continuesly backup i would entrust you „back in time“)

share|improve this answer
2  
Doesn't seem to work. From a googling, it seems an option associate to compact_view. –  enzotib Jan 25 '12 at 15:12
    
based on this: people.gnome.org/~bmsmith/gconf-docs/C/nautilus.html all_columns_have_same_width isn't in the nautilus schema. –  senshikaze Jul 6 '12 at 14:08
    
Confirmed for 12.04: doesn't work, even crashed my Nautilus. So I removed the key again... –  isync Jan 4 '13 at 0:07
    
Didn't work for me. –  Sri Jun 21 '13 at 8:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.