Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Good afternoon,

Earlier today I removed libjpeg (because I felt it needed to be reinstalled to fix this ghostscript related error). Unfortunately it removed a bunch of software along with libjpeg.

When I rebooted, I had nothing. So I went to tty2 and installed ubuntu-desktop. After reboot, X still doesn't start by default, I have to switch terminals and run it manually.

Unfortunately, it doesn't load the boundaries of the windows, alt-tab doesn't work, and the minimize/maximize/close options are unavailable.

How do I finish restoring my Ubuntu 11.10 x86_64 OS?

Thanks for all suggestions,

Alec Taylor

share|improve this question

Run the program

/usr/lib/nux/unity_support_test -p

to test if your graphics supports compiz/unity.

If not, you should use the classic desktop: install the package gnome-session-fallback and at the login choose Gnome Classic (click on the gear near the username).

share|improve this answer
It was all working fine with Unity 3D before I ran apt-get remove libjpeg. So I'm sure my graphics support it. – A T Oct 23 '11 at 10:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.