Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I am having trouble with Ubuntu 11.10 to the workgroup containing windows computers.

I am getting this message when I click on the workgroup I want to access from the Ubuntu Network interface:

"Unable to mount location  
Failed to retrieve share list from server"

How can I solve this problem?

Output of sudo iptables -L:

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination  

Every time I try to connect to my windows shares using

sudo mount -t cifs //ip_from_windows_pc/sharename /media/winshare -o username=windows_username,password=windows_password_for_user,iocharset=utf8,file_‌​mode=0777,dir_mode=0777

it returns

mount: Cannot allocate memory

I have noticed that on the system event log in Windows I also get this fault every time I try to connect with the Ubuntu computer

The server was unable to allocated from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

share|improve this question
    
dont forget to reboot your windows! (hope this works) –  Bruno Pereira Oct 26 '11 at 10:13
    
@drtanz Can you please update your question to include all the new information you've provided in the comments? This will help other users who wish to assist get to the information quicker :) –  Marco Ceppi Oct 26 '11 at 13:24
    
@MarcoCeppi done –  Bruno Pereira Oct 26 '11 at 14:08
1  
@drtanz I have updated your question to include all the information in these comments, hope that was ok. –  Bruno Pereira Oct 26 '11 at 14:08
    
yep no problem thanks –  drtanz Oct 27 '11 at 8:51

2 Answers 2

up vote 5 down vote accepted

In your Windows computer set the following registry key to ’1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ’3′:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

No ``, just the values.

Reboot!

share|improve this answer
    
Finally got it to work! :D Thanks! –  drtanz Oct 26 '11 at 11:00
    
So glad this helped!, sorry for the extensive trouble shoot but it was worth it! :) –  Bruno Pereira Oct 26 '11 at 14:04
    
Yes definitely, thanks for your patience, now on to trying to understand why I can't see the linux shares from windows :) –  drtanz Oct 26 '11 at 14:44
    
@drtanz Add another question if needed but I am sure that a question like that was already answered many many time, have a look around first. :) gl –  Bruno Pereira Oct 26 '11 at 14:47
    
After doing this, I was finally able to go beyond the icon representing a Windows 7 machine in the Browse Network folder at Ubuntu. But it doesn't show the folder I explicitly shared with everyone. :( –  Oxwivi Oct 26 '11 at 16:32

I also had some problems sharing folders. I installed samba but when restarting samba after changing the smb.conf file i got a message that samba wasn't installed and that i needed to install samba4. After installing samba4 it still didn't work and i did a bit of google magic and found out that on Ubuntu 11.10 you need to install the system-config-samba package.

First you need to install the system-config-samba package. Open a terminal (press SuperKey and type terminal) and copy+paste the following line:

sudo apt-get install system-config-samba

When the package is installed close the terminal window and press Alt+F2 and type: samba. Click on Preferences and select the server settings. In the Workgroup text field you need to enter the name of your windows network. When done you can close the samba server configuration window.

To share a folder click with your right mouse button on the folder that you want to share and choose Sharing Options. Click on the checkbox in front of Share this folder and enable allow others to create and delete files and guest access if you want. If you don’t enable guest acces then you will need to make a new user account on Ubuntu and use that account to get acces to the shared folder from a windows machine. Now clcik on the Create Share button and on the Add the permissions automatically button.

If you are asked for a username and a password when trying to open your shared folder you must add your Ubuntu account to the Samba user database. To do that copy+paste the following line in a terminal window:

sudo smbpasswd USERNAME -a

First you will be asked for your password and after that you need to enter a new samba password. Replace USERNAME with your username

If you can’t detect the shared folder on windows 7 make sure that file and printer sharing is enabled.

To enable file and printer sharing on windows 7 start Windows and in the search box type:

manage advanced sharing settings

Under Public folder sharing enable the Turn on sharing option and restart Windows.

share|improve this answer
    
I did this but I still can't see the shared folders from win 7 –  drtanz Oct 26 '11 at 15:01
    
I'm sorry but i can't help you fix it. It took me an afternoon to fix my own shared folder in my network and i fixed it using the manual above. –  tinuz Oct 27 '11 at 9:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.