Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since I connected my HDTV to my Ubuntu system, Ubuntu has wanted to use it as the primary display.

I thought I had this fixed up through 11.04, but I do not remember how, and now with 11.10 the login box is showing up on the HDTV again.

This is a problem for me because normally the HDTV is (a) set to a different input source and (b) turned off. Now I have to turn it on and change the input source every time I want to log in or launch an application.

How can I configure 11.10 to use the correct monitor as the primary?

Thank you.

share|improve this question
1  
Try turning off the secondary display(HDTV) in "Monitors" application, and turning it back again. –  Capt.Nemo Oct 22 '11 at 17:00
add comment

3 Answers 3

Usually you switch the default display in Ubuntu's own display manager. It goes like this:

Dash display settings

However, depending on your GPU driver you might need to use another application than the display manager instead. Since I have an nVidia Graphics card for instance, the display manager won't work for me. I have to use the NVIDIA X Server Settings manager, shown in the picture below:

Nvida Display Manager

share|improve this answer
add comment

If you have an ATI graphic card, I suggest you to manage primary screen by modifying ~/.config/monitors.xml

enter image description here

share|improve this answer
add comment

First list all displays with:

xrandr --prop

Display names will look like DVI-1, HDMI-0, VGA-1 and so on. Find the display you want to make primary and run the following command:

xrandr --output DVI-1 --primary

Where DVI-1 is the display you chose.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.