Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I need to use Linux 3, becasue with Linux 2.6.x has display problems with my SandyBridge integrated graphic. On the other hand, I need to downgrade to Ubuntu 10.04/10 because Betavine packages for running my mobile broadband modem work only with Ubuntu 10.04 (and 10.10). Hence I need to make a compromise. I appreciate your hints.

share|improve this question
Sandy bridge works OK on the natty kernel - if you start from 10.04 - you can use this answer here to upgrade graphics and the kernel to work with your sandybridge laptop.… – fossfreedom Oct 24 '11 at 19:49
FYI, the difference from 2.6.x to 3.0.0 is nothing. It was just a version bump from Linus =P – Githlar Feb 20 '12 at 16:23
I have 3.2.4 installed in Natty I just went to the mainline and downloaded the .DEBs – Ringtail Mar 10 '12 at 17:21

2 Answers 2

Or, as a last-ditch effort you could compile a new kernel from and use that.

To get an ubuntu-styled kernel:

apt-get source linux-image-$(uname -r)
cd linux-image-$(uname -r)
make menuconfig #Then hit exit and save the configuration
cd ..
tar -xjf linux-3.2.6.tar.bz2
cd linux-3.2.6
make menuconfig
cp ../linux-image-$(uname -r)/.config .
rm -R ../linux-image-$(uname -r)*
make install
share|improve this answer

Maybe. There is an Ubuntu kernel PPA:

You can try download the Linux kernel 3 for Oneiric, maybe it will work.

share|improve this answer
you can't use a oneiric kernel for a Ubuntu versions that's not Oneiric! – Alvar Feb 20 '12 at 16:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.