Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recovered my music collection from my iPod after I lost a hard drive, via drag and drop from banshee to my music directory.

Banshee started organizing the files according to tags after finishing the copy-process, but stopped after about 10% of my collection. How can I force it to continue?

Restarting Banshee and disabling and enabling the 'update files' option didn't help. Thanks :-)

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

You can remove your database to force banshee to create a new one.

The database file is located in ~/.config/banshee-1 and its called banshee.db.

Quit banshee (make sure that its really closed)

Created a backup of the database named banshee_bak.db

mv ~/.config/banshee-1/banshee.db ~/.config/banshee-1/banshee_bak.db

Open banshee again and re-index your media.

share|improve this answer
    
mmh... after I did this, banshee starts re-indexing my files but hangs after a few seconds. GLib.MissingIntPtrCtorException: GLib.Object subclass Banshee.Gui.Widgets.TaskStatusIcon must provide a protected or public IntPtr ctor to support wrapping of native object handles edit: I wonder if this is related at all to my original problem? –  haunserein Oct 22 '11 at 15:10
    
I would believe so, maybe a complete removal and reinstall from banshee? sudo apt-get clean banshee will remove and delete config, sudo apt-get install banshee will get it back. The recommendation I gave came straight from banshee so it should work. Open it next time from the terminal to check any further errros –  Bruno Pereira Oct 22 '11 at 15:13
    
reinstalled banshee, new db was created without any errors, but still no progress on the files :-( I figure banshee might be checking album-covers etc. (I could see it was busy recognizing and writing bpm-speeds, so I disabled that feature for now) for the entire library, so I'll just let it run for some time and check back on my folders in a few hours. –  haunserein Oct 22 '11 at 15:42
    
gl, anything add a comment –  Bruno Pereira Oct 22 '11 at 15:46
add comment

This did the trick for me:

  1. Remove all music from the library
  2. Make the changes
  3. Restart Banshee
  4. Check the settings are still there
  5. Import media.
share|improve this answer
    
Thanks. This worked for me. –  yasar May 3 '12 at 15:19
    
Re-importing worked for me as well. There should be a "cleanup files and folders" feature. IIRC iTunes has this. –  Rafael Vega May 25 '12 at 23:12
add comment

I wrote a little tool for this exact purpose because I didn't want to lose my ratings, playcounts etc.

It can be found at: https://bitbucket.org/moi90/bansheeorganizer. If you don't want to clone the repo, just download https://bitbucket.org/moi90/bansheeorganizer/raw/tip/BansheeOrganizer.py and run: python BansheeOrganizer.py

The programm will use the default location of the Banshee database file (~/.config/banshee-1/banshee.db) and automatically detect the location of the media library (e.g. ~/Music) as well as the naming pattern.

For each track in the database the media file will be moved appropriate to the media library location, the naming pattern and the track data and the database record will be updated.

Warning: USE AT YOUR OWN RISK. The database file may be corrupted and music files may be lost.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.