Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't find a solution for my problem online:

I'm running Unity 2D in Ubuntu 11.10 and want to enable compiz effects. I installed compiz config settings manager, and Fusion-Icon, but when I start Fusion-Icon nothing happens. When I execute it from terminal it stucks at lines like "setting update 'command'" or "setting update 'next_key'"

I already set the whitelist for the panel to 'all'.

Anyone knows what I'm missing? Thanks in advance!

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Try Displex. It provides the same options as the Fusion Icon, and works with Unity/AppIndicators.

(It will also work in most other desktop environments where you can run compiz).

Note, if it does not run try the following:

I installed the deb and tried starting DisPlex from the app menu but nothing
happened. So I ran "indicator-displex" from terminal. At some point it showed
"Value error: gconf key /apps/nautilus/preferences/show_desktop has no value"
so I had to manually add a value and typed
gconftool-2 --set "/apps/nautilus/preferences/show_desktop" --type bool true
ran it again and got the same error for
/apps/gnome-screensaver/idle_activation_enabled,
so the same procedure and that was it.

Taken from Schubibuntu's comment.

share|improve this answer
    
Thanks, I tried that and it worked. Although I had to solve some smaller problems that I'd like to post for later visitors: –  Schubibuntu Oct 23 '11 at 6:47
1  
I installed the deb and tried starting DisPlex from the app menu but nothing happened. So I ran "indicator-displex" from terminal. At some point it showed "Value error: gconf key /apps/nautilus/preferences/show_desktop has no value" so I had to manually add a value and typed gconftool-2 --set "/apps/nautilus/preferences/show_desktop" --type bool true ran it again and got the same error for /apps/gnome-screensaver/idle_activation_enabled, so the same procedure and that was it. So again, thanks Roland ;-) –  Schubibuntu Oct 23 '11 at 6:54
    
@Schubibuntu: glad to help :D! You can edit those details into my answer :) –  RolandiXor Oct 23 '11 at 11:33
add comment

Most likely you are missing the "Notification Area" from your top panel. To add it, Super+Alt + right-click on the top panel, and double-click "Notification Area"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.