Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In a fresh copy of 11.10, I can't upload files using FTP to a server, while I can with SFTP. Is FTP upload (i.e., outgoing transfer) disabled by default? I can log in to the FTP server and, but can't upload files. If it is disallowed by default, how can I enable it?

ADDED: If I use Filezilla, everything works good. However, if I use ftp command I obtain the following error:

200 PORT command successful
425 Could not open data connection to port 38505: Connection timed out

However, with sftp command, it works.

share|improve this question
    
What program are you using? Do you have permissions for writing on the FTP? What fault do you get? –  Bruno Pereira Oct 22 '11 at 14:43
    
@brunopereira81 I added more details. Thanks. –  FEQ Oct 22 '11 at 15:06
    
Are you sure the port is 38505? Normal FTP port is 21 (maybe you already know that, just checking). What is the server like? Could you connect using another client maybe? Connection timeout normally means the server did not respond to your request, maybe you need to enable PASV mode some servers require that (uses 20 and 21 to communicate instead of just 21). –  Bruno Pereira Oct 22 '11 at 15:09
    
@brunopereira81 I have no idea of what that port number is. The port number 38505 changes every time. You were correct! passive mode works!!!! Can you add as an answer? –  FEQ Oct 22 '11 at 15:14
    
@Chang already added one, vote up and mark complete. –  Bruno Pereira Oct 22 '11 at 15:17
show 1 more comment

2 Answers

up vote 2 down vote accepted

Your server is refusing connection, if you are sure about all the details of it try using passive mode, some servers require it.

share|improve this answer
add comment

Can you upload to the same FTP server via other means (Windows, or earlier versions of Ubuntu)?

Because, it is highly unlikely that you are unable to upload to FTP due to a client side issue. You can try installing a dedicated FTP client (like Filezilla), and see if that helps you; but most probably it is a server side issue.

share|improve this answer
    
Filezilla works. Please see added details. Thanks. –  FEQ Oct 22 '11 at 15:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.