Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When my Dell Vostro laptop is connected to the power, the screen is dimmed after 10 seconds. This is very annoying.

When my laptop is running on the battery, the screen is not dimmed after inactivity, this is what I want.

When I go to System settings → Screen, the Dim screen to disable power option is disabled.

How can I disable screen dimming after inactivity totally? I'm running 11.10.

When I create a new user account I don't have this problem. I have changed some settings with CompizConfig Settings Manager and with gconf, but I can't find timeout options for brightness.

share|improve this question

2 Answers 2

Caffeine

You could try using caffeine. When you activate caffeine the screen wont fall a sleep or get dimmed, you can set it up in different ways.

  • You can find more info here, or on launchpad.
  • And install the program by typing sudo apt-get install caffeine
share|improve this answer
    
How can I make the settings the system default? What settings will I loose when I do that? That fixed the same problem for you? –  i.amniels Oct 23 '11 at 9:51
    
You wont lose any setting you will just make all of you settings the default for other programs, it's a sort of "fix" or a "workaround". –  Alvar Oct 23 '11 at 10:14
    
Thanks. Caffeine fixes the problem, but now my monitor doesn't turn off after 5 minutes of course. So cafeine is not a final solution for me. I think you are showing an older version of the power settings, in 11.10 this has been changed. Make default is not there. –  i.amniels Oct 23 '11 at 10:52
    
ooh, sorry didn't know that they had changed. –  Alvar Oct 23 '11 at 11:28

By default, the dimming checkbox at System Settings > Screen is disabled. So I enabled it and then again disabled it. Worked for me.

share|improve this answer
    
Good to hear. Did you report a bug on Launchpad.net? Please do so. That way the problem can be fixed and not just circumvented. –  Jo-Erlend Schinstad Jan 1 '12 at 23:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.