Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Fonts are displayed a little bit blurry on my TFT screen. I fixed this in previous Ubuntu releases by enabling sub pixel hinting in the font settings. But now I can't find any font settings dialog in Unity. How can I enable sub pixel hinting or change the font family or font size? Where is all this stuff?

share|improve this question
add comment

2 Answers

up vote 9 down vote accepted

Welcome to the new no-user-serviceable-parts-inside Ubuntu/Gnome.

Install gnome-tweak-tool (sudo apt-get install gnome-tweak-tool) and run it (it's called "Advanced Settings"). The font settings are in the Fonts tab.

share|improve this answer
add comment

The easy answer is "apt-get install gnome-tweak-tool", but that has the downside of pulling in gnome-shell and lots of associated packages.

You can do it on the command line using gsettings. For example:

$ gsettings get org.gnome.settings-daemon.plugins.xsettings hinting
'slight'
$ gsettings set org.gnome.settings-daemon.plugins.xsettings hinting full
$ gsettings get org.gnome.settings-daemon.plugins.xsettings hinting
'full'

Valid values appear to be "none", "slight", "medium", "full".

You can also configure the antialiasing settings in a similar way.

$ gsettings get org.gnome.settings-daemon.plugins.xsettings antialiasing
'rgba'
$ gsettings set org.gnome.settings-daemon.plugins.xsettings antialiasing none
$ gsettings get org.gnome.settings-daemon.plugins.xsettings antialiasing
'none'
$ gsettings set org.gnome.settings-daemon.plugins.xsettings antialiasing grayscale
$ gsettings get org.gnome.settings-daemon.plugins.xsettings antialiasing
'grayscale'
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.