Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I reset my Unity configuration?
How do I reset GNOME to the defaults?

Apparently I've messed up a lot with my Unity and Gnome 3 settings and now my system looks ugly, and even if I made changes (using gnome-tweak-tool for example) to my configuration nothing seems to work. Can you guys tell me how to delete all the Unity and Gnome related settings (like also compiz and all other similar ones) and restart with the settings of an installation from scratch??

I'd really appreciate your help, thanks a lot guys!

share|improve this question

marked as duplicate by Jorge Castro, SirCharlo, Eliah Kagan, Mitch, John S Gruber Sep 7 '12 at 18:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Possible duplicates - askubuntu.com/questions/56313/… - askubuntu.com/questions/17610/… –  jrg Oct 27 '11 at 12:20

4 Answers 4

This worked for me! I've just reset a broken Unity desktop where my user's theme had turned ugly and the dash and top left tray and system menu had stopped appearing. None of the apps seemed to be broken, it was only the very desktop environment I wanted to reset. I did this by moving these two directories out of the way: ~/.config/compiz and ~/.config/dconf. Before I reached to this conclusion, I had run "unity --reset" and "unity --reset-icons", but as far as I could tell, they didn't influence my setup one bit.

Instructions:

  1. Log out of X. I can't do this, since my logout menu didn't appears.

  2. Find a virtual terminal (press Ctrl+Alt+F1) and login.

  3. Kill X if you can't logout:

    sudo killall Xorg
    

    X will die, restart, and switch virtual terminal. Switch back with Ctrl+Alt+F1.

  4. Then run:

    mv -v ~/.config/compiz-1 ~/.config/compiz-1.BROKEN
    mv -v ~/.config/dconf ~/.config/dconf.BROKEN
    
  5. Then go back to X (Ctrl+Alt+F7) and login.

You should now have been set back to a working Unity desktop environment, but without resetting any of your application settings. Also, you can restore the directories, if you wish, since they where just renamed and not deleted.

share|improve this answer
    
Works perfectly, thanks –  Some Noob Student Mar 11 '12 at 20:06
    
Thanks, it solved my issue: askubuntu.com/q/262195/563 –  Maciej Mar 1 '13 at 1:19
    
Thanks @david6 your solution worked for me too in askubuntu.com/questions/364958/restore-old-desktop –  Huseyin Nov 9 '13 at 15:47
  1. If you want to reset Unity (this will only reset the Unity settings in CompizConfig Settings Manager and leave the other CCSM settings intact), open a terminal (or press ALT + F2) and enter:

    unity --reset
    
  2. If you want to reset the Unity Launcher icons (dock bar on the left) to their initial state, run the following command:

    unity --reset-icons
    
share|improve this answer
    
Hi enzotib, this doesn't work. What I'd like is removing al my settings (not only the user but also the systems one). Of course I don't want to remove ALL my settings (rm -r .* is not a good choice for me...) but only the unity compiz and gnome related ones. Both user and system wide. Also I could reinstall al the default packages, but I can't find a list for them! –  lucacerone Oct 22 '11 at 10:07
    
The default applications are available as a package called ubuntu-desktop. If you install it, you'll install all the defaults. You'll not remove non-defaults, though. –  Jo-Erlend Schinstad Oct 26 '11 at 12:16
    
Thanks for the tip about using --reset-icons. I didn't know about that one. :) –  Jo-Erlend Schinstad Oct 26 '11 at 12:42

Try these three commands:

gconftool-2 --recursive-unset /apps/compiz-1

unity --reset &

rm -rf .gnome .gnome2 .gconf .gcond .metacity

Then, restart PC

NEXT TIME: install 'Ubuntu Tweak', and backup your desktop settings

sudo add-apt-repository ppa:tualatrix/next

sudo apt-get update

sudo apt-get install ubuntu-tweak [0.6 beta, Oneiric capable]

sudo apt-get install ubuntu-tweak-0 [old version]

share|improve this answer
    
Thanks David, I'll try this as soon as I get to the broken computer :) (Particularly useful is the advice for Next Time :)) –  lucacerone Oct 26 '11 at 12:16
1  
Won't that also delete your keyrings? You should be careful when you recommend that users delete folders. –  Jo-Erlend Schinstad Oct 26 '11 at 12:27
    
Suggest to replace "rm" with "mv" to some <samename>.bak backup files and dirs –  cfi Nov 6 '11 at 14:20
    
Also add ~/.cache ~/.compiz*~/.fontconfig ~/.local ~/.themes - I'm still unsure if this is a complete list or if some of these are not required to restore unity & gnome3. I'm having the same issue. –  cfi Nov 6 '11 at 14:23
    
With all of these (original answer plus my comment) moved, Gnome3 again works as expected. Unity desktop still only shows a stripped down desktop with no launcher at all, no lenses anywhere, and the base menu in the top bar –  cfi Nov 6 '11 at 18:58

You can try and identify where the config files that are causing problems are by creating a new user in user accounts. Now if you log into the new user you have created and everything looks fine then you must still have bad settings in your home directory.

You can try moving hidden config folders until you find the one containing the unity/gnome settings.

If your settings are still wrong for the new user then system level config files have been changed, to remove these changes use:

sudo apt-get -o DPkg::options::=--force-confnew --reinstall install <package>

This will force dpkg to replace modified config files with the original ones losing all post install customizations. Check man dpkg for more details

share|improve this answer
    
This is a good advice! I'll try it as soon as I'm in my office! In the meanwhile can you please tell me which are the packages controlling gnome, unity and compiz??? Thanks a lot!!! –  lucacerone Oct 22 '11 at 18:24
    
Use a package manager like synaptic to see unity and compiz's dependencies, as those packages are metapackages and don't actually install anything. Its a lot easier if you remember which conffiles you edited because then you can just use dpkg -S /etc/compizconfig/config, which will give you the owning package of the file you give it.Then you can use the above command to restore the conffile. –  Anarci Oct 23 '11 at 12:13
    
Hi Anarci. I've created a new user and its Unity session looks fine. So does the Gnome Classic session. But the Gnome session doesn't look like standard Gnome 3 session, it still looks like the Gnome Classic one. I've tried the command for the Gnome package, but nothing changed. What other can I try? –  lucacerone Oct 24 '11 at 7:38
    
I'm not sure what else to try. cd ~; rm -rf .gnome .gnome2 .gconf .gconfd rather move the files instead of deleting them. These are where all the gnome conf user files are stored but if gnome session looks strange between users I'm not sure what else to try. Maybe posting a screenshot will help? –  Anarci Oct 24 '11 at 10:17
    
Before that you can try gconftool-2 --direct \ --config-source user-configuration-source \ --recursive-unset to restore default preferences of a user –  Anarci Oct 24 '11 at 10:22

protected by Community Mar 5 '12 at 22:00

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.