Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I directly connect to Server A, using public key auth from my computer, it takes <0.5 s. But if run the same ssh command from Server B (to connect to Server A) it freezes for about 15 s at the following line : (complete log)

debug2: ssh_connect: needpriv 0

Since I can ssh normally, I assume it is a configuration issue in Server B.

Also, I've tried sshing from B to A, using another account (with password auth). It too hangs at the same line for the same amount. This leads me to believe that it is system ssh config issue, so I'm posting my /etc/ssh/ssh_config as well.

I ran a diff of my ssh_config vs Server B's. The result gave no dissimilarities.

Both Server A and B are running Lucid.

share|improve this question
1  
Try with "GSSAPIAuthentication no" in /etc/ssh/sshd_config –  nsg Oct 22 '11 at 8:54
    
@nsg Tried, still hangs –  Capt.Nemo Oct 22 '11 at 8:57
    
Could be a DNS problem. Do you still get the delay if you use the IP adress instead of the host name? –  Florian Diesch Oct 22 '11 at 11:09
    
@FlorianDiesch right on mark. Could you please post that as an answer, thanks. –  Capt.Nemo Oct 22 '11 at 11:16
add comment

2 Answers

up vote 3 down vote accepted

Could be a DNS problem. Do you still get the delay if you use the IP adress instead of the host name?

share|improve this answer
add comment

DNS could be the cause mostly.

To verify if it's stemmed from DNS resolution , try to disable DNS verification by putting the following into sshd.conf on your server:

UseDNS No
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.