Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting the following error in the top menu bar:

"An error occurred.Please run the Package Manger form the right-click menu or apt-get in a terminal to see what is wrong.The error message was:'Error:BrokenCount>0'.This usually means that your installed packages have unmet dependencies."

share|improve this question
1  
Please open a gnome-terminal, run sudo apt-get check, and add the output to your question. –  htorque Oct 22 '11 at 7:48
    
I typed sudo apt-get check.I got the following: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libasound2-plugins : Breaks: libasound2-plugins:i386 (!= 1.0.24-0ubuntu6.1) but 1.0.24-0ubuntu6 is installed libasound2-plugins:i386 : Breaks: libasound2-plugins (!= 1.0.24-0ubuntu6) but 1.0.24-0ubuntu6.1 is installed E: Unmet dependencies. Try using -f. –  Pulkit Chaudhary Oct 22 '11 at 11:22
    
Now try sudo apt-get install -f. –  htorque Oct 22 '11 at 11:25
    
I tried it.nothing happened.I even tried sudo apt-get update.but still no use. Then i tried sudo rm /var/lib/apt/lists/* -vf It removed all the packages.then i tried sudo apt-get update.After the execution of it, i opened Ubuntu Software Center and clicked repair on the dialog box that appeared.And everything is fine now. Thank you for the help. –  Pulkit Chaudhary Oct 22 '11 at 18:12
    
If that fixed your issue, please add it as new answer and accept it by clicking on the checkmark left to the answer (but I think this will only work after a day or two). –  htorque Oct 22 '11 at 18:18

2 Answers 2

I tried

sudo rm /var/lib/apt/lists/*-vf

. It removed all my packages. Than i tried

sudo apt-get update

. It installed new packages again. After that i opened Ubuntu Software Center and a dialog box appeared saying that i needed to repair some broken dependencies.I clicked on the Repair button. And the problem was resolved. Note- You must have a good internet connection for this process.

share|improve this answer

Open the Software Center. It may automatically recognize the problem, and ask you for permission to fix it. If so, let it. (That fixed this for me.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.