Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't know if I have the terminology correct. Fresh-installed 11.10 today. But the bar on the left of the screen that auto-hides, and the menubar at the top of the screen along with the notification area were there the first few times I rebooted, but are now all gone.

All I have is the desktop, with the icons on my desktop, and the default background. I cannot get to a terminal except for full-screen CTRL+ALT+F1. Only way I got Firefox to start is by right-mouse-click on the desktop and creating an empty test.html file.

How can I debug what has gone wrong? What log files should I be looking at? The thing that should be on the left, that's called Launcher or Dash, right? Where would I look to see why/how/where it is crashing?


May as well add some comments as I discover things:

  1. press CTRL+ALT+F1 to get to the full-screen command-prompt
  2. run: export DISPLAY=:0
  3. run: unity &
  4. run: unity-2d-launcher &
  5. press CTRL+ALT+F7 to get back to a semi-usable desktop

The question still remains: why are these not starting up by themselves...

share|improve this question
    
Does this issue survive reboots? You can put those commands into a script on your desktop so that if it does, you won't have to switch TTYs again. I think you can leave off the export line. If it does survive reboots, please run unity --reset & disown and try rebooting again. –  Kevin Oct 22 '11 at 3:05
    
Yes, it survives a reboot. If I choose Ubuntu-2D instead Ubuntu, then everything works. But I created another test account, and with that one Ubuntu works fine. Must be a setting I changed. Wondering if I can delete some ~/.file and have it work again. –  Stéphane Oct 22 '11 at 3:41
    
Did you try unity --reset &? That should reset all of your Unity options. –  Kevin Oct 22 '11 at 4:40
    
Yes, I also tried that, didn't work. What finally worked is I logged in a test account I'd created, then with sudo rm I deleted almost all of the ~/.files and ~/.directories that had been created. Once I re-logged in as myself, the startup sound worked again, and it re-created everything it needed as if I was a new user. I'm good, problem is "solved" for now... Thanks. –  Stéphane Oct 22 '11 at 5:45
    
I've come across the exact same issue - sometimes if you mess around too much with Compiz it will disable the Unity Shell so when you next log in you get no usable desktop other than the top menu bar. Logging into a Unity 2D session and enabling the Unity Shell plugin in CCSM fixes it - I've also had to fix some keybindings when doing this. –  Mark Rooney Oct 22 '11 at 7:16
add comment

1 Answer

Try ~/.xsession-errors and /var/log/Xorg.0.log

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.