Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an alps touchpad on my laptop. It never got detected as a toupad in ubuntu <= 11.04. Finally with 11.10, it finds it as a touchpad and in the mouse config I can see a touchpad tab.

Changing the settings in the mouse config do nothing.

xinput -list gives:

 Virtual core pointer                        id=2    [master pointer  (3)   
  ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]   
  ↳ HP Wireless Optical Mobile Mouse            id=9    [slave  pointer  (2)]   
  ↳ AlpsPS/2 ALPS GlidePoint                    id=13    [slave  pointer  (2)]   
  ↳ PS/2 Mouse                                  id=12    [slave  pointer  (2)]    

(HP optical is my external mouse)

When I

xinput set-int-prop 12 252 8 3.5

It changes the touchpad sensitivity. So I gather the system is using the PS/2 mouse driver to control the touchpad. Disabling the PS/2 mouse disables the touchpad. Disabling the AlpsPS/2 glidepoint does nothing.

When I do
dmesg | grep -i input I get:

[   17.613230] input: PS/2 Mouse as /devices/platform/i8042/serio1/input/input11    
[   17.638723] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio1/input/input12

So this makes me thing the PS/2 mouse drivier is loading first, thus using those drivers instead of the touchpad drivers.

blacklisting psmouse disables the touchpad.

I am now out of ideas on how to get my touchpad behaving as a touchpad. More specifically I want to disable it as I type, increase sensitivity and have side scrolling back.

Unless someone has other thoughts...how can I change the order it loads the devices...make it load the touchpad first? Or is there another solution?

share|improve this question
    
I have this same problem. –  Random832 Feb 19 '12 at 1:02

1 Answer 1

The psmouse driver is responsible for handling all mice and touchpads that use the PS/2 bus, even though many of them (including most touchpads) support some kind of "extended" protocol. Thus, it's normal to see the PS/2 driver loading and then indicating it found an ALPS touchpad, which it handles internally.

Go look in /lib/modules/3.0.0-16-generic/kernel/drivers/input/mouse and you'll see there is no "alps" driver proper, notice too that psmouse.ko is by far the largest driver, since it handles a lot of PS/2 protocol extensions internally (like ALPS, Elantech, some Synaptics, and others).

This is just an explanation, I'm sorry I don't have a real solution for you, you may want to go have a look at this bug report to see if it applies to you, and if so, to track the status of any possible solutions.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625

share|improve this answer
    
The psmouse_alps_dkms driver in the comments there helped some, but my hardware acts flaky enough with it (it acts flaky with the real ALPS driver on windows, to, my computer shipped with a custom driver) that I gave up. –  Random832 Feb 19 '12 at 5:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.