Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Oneiric 11.10, Unity 2D, and compiz (modifying some ccsm settings); I've activated the effects plug-in on ccsm, and when I apply the changes by typing in the terminal compiz --replace, I get two title bars in a maximized window rather than only one, the first: the one which is integrated with the unity bar, and the other: the one of the window.

Here are some pictures:

share|improve this question
    
Did you uninstall the unity package? Someone else in a recently-closed question had a similar problem caused by that. –  WarriorIng64 Oct 24 '11 at 2:28
    
Remarkably - I think this has just been answered... askubuntu.com/questions/71369/compiz-issues-in-unity-2d –  fossfreedom Oct 24 '11 at 16:17
add comment

3 Answers

up vote 8 down vote accepted
+50

To solve the window decorator issue, simply run the following in the terminal or Alt+F2 and the window decoration will immediately disappear:

gconftool-2 -s -t string '/apps/compiz-1/plugins/decor/screen0/options/decoration_match' '!state=maxvert'

Or just as @joschi's answer suggest, you can do that graphically using the CCSM:

enter image description here

share|improve this answer
add comment

I have set myself the 'decorations for windows' box to !(state=maxvert & state=maxhorz) because I do want the decorations when the window is only vertically/horizontally maximized (by clicking the maximize button with the middle/right button, respectively), and I do not want them if it is fully maximized.

share|improve this answer
    
Excellent! No one seems to be mentioning state=maxhorz, but that is important, especially if you want to use the Window Grid plugin. I tried maxhori and maxhoriz and neither worked; should have figured this out. Took some searching. +1 upvote this answer people. –  Kazark Jul 7 '12 at 16:32
add comment

You can try to change the settings in the 'Window decorations' option in CCSM. Type !state=maxvert in the 'decorations for windows' box which should remove the decorations of all maximized windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.