Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my parents' computer from an old (9.04) Ubuntu to 11.10. And...11.10 automatically installs the driver for the wireless adaptor, which is nice. But the computer can't pick up the router's SSID. It's a brand new Netgear 600 router. All the other computers in the house work fine. Connecting to it as a hidden network works fine. I've done wireless setup several times before on various flavors of GNU/Linux, and it looks to me like everything is setup properly, but it doesn't seem to see the router when disconnected.

Any suggestions?

lspci -v:

04:01.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI
    Subsystem: Giga-byte Technology GN-WP01GS
    Flags: bus master, slow devsel, latency 64, IRQ 18
    Memory at febf8000 (32-bit, non-prefetchable) [size=32K]
    Capabilities: <access denied>
    Kernel driver in use: rt61pci
    Kernel modules: rt61pci

lshw -C network

*-network
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: Ralink corp.
       physical id: 1
       bus info: pci@0000:04:01.0
       logical name: wlan0
       version: 00
       serial: 00:24:1d:99:51:20
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci driverversion=3.0.0-12-generic firmware=0.8 latency=64 link=no multicast=yes wireless=IE$
       resources: irq:18 memory:febf8000-febfffff

(when disconnected) iwlist wlan0 scan:

wlan0     No scan results

(when connected) iwlist wlan0 scan:

wlan0     Scan completed :
          Cell 01 - Address: C4:3D:C7:64:13:B2
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=61/70  Signal level=-49 dBm  
                    Encryption key:off
                    ESSID:"NETGEAR"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000286beb440dc
                    Extra: Last beacon: 60ms ago
                    IE: Unknown: 00074E455447454152
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A7C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606001300000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD7E0050F204104A00011010440001011041000100103B0001031047001058B973F0430A08BD74F1EA1F36FEB45F1021000D4E4554474541522C20496E632E10230008574E44523334303010240008574E4452333430301042000230311054000800060050F204000110110008574E445233343030100800020084103C000103
                    IE: Unknown: DD090010180203F0050000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C337C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3406001300000000000000000000000000000000000000

dmesg, in case that's any use... http://pastebin.com/ebpjssCs

share|improve this question

2 Answers 2

Ok, i had the same issue after a netboot install : no wifi access point was listed by network-manager

What i did : clean /etc/network/interfaces , delete all connection entries in network manager applet (wired, wifi...)

And a last reconfiguration for the network-manager

sudo dpkg-reconfigure network-manager
share|improve this answer

Suggestion : clean up Network-Monitor connections entries and /etc/network/interfaces

Remove all connection entries in the wireless pane of Network-Monitor applet.

Clean up your /etc/network/interfaces : loopback only

/etc/network/interfaces

auto lo
iface lo inet loopback

Then restart the network-monitor service

share|improve this answer
    
This is a brand-new Ubuntu install /etc/network/interfaces has never been anything but clean. And I have tried several times deleting the wireless connection(s) in the applet. Doesn't change anything. Very odd -- everything I can see by whatever method seems to be OK except that it doesn't catch the broadcast SSID. And it worked fine this morning under 9.04, so the hardware should be fine... –  Joshua Grams Oct 21 '11 at 21:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.