Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to configure am OpenVPN client on my laptop. I am running Ubuntu 11.10 64-bit.

When I open network manager and import the VPN settings from the premade config folder everything takes. The problem is when I try to save the settings, the save button at the bottom of the network manager applet is greyed out. Further more when I hover over the button it says Authenticate to save this connection for all users of this machine. The problem is I did not check the box Available to all users it was already checked and it is also greyed out and won't let me manipulate it.

What is going on? Is this a bug or is there something I am missing?

Any help would be wonderful.

share|improve this question
    
What kind of VPN connection are you setting up? –  cprofitt Oct 21 '11 at 18:49
    
OpenVPN using SSL certs –  Solignis Oct 21 '11 at 19:02
1  
I will load that option up on my test box tonight if I can and see if there is a bug. –  cprofitt Oct 21 '11 at 19:25
    
I tested on two boxes and could not reproduce the issue. –  cprofitt Oct 24 '11 at 21:36
1  
This must be a bug! If you choose type "password" it should obviously NOT ask for more authentication... Stupid OpenVPN... –  user35029 Nov 23 '11 at 8:34

3 Answers 3

I had this problem too, I don't know if I could reproduce it but what I did to get round it was to change the VPN type from certificates(TLS) to password with certificates, then put in some junk text into the two password fields and fiddled with the dropdown for saving the passwords, it then let me save the connection and did store those passwords, that seemed to get it over the problem of not saving the password so I then set it back to certificates(TLS) and put in the real private key password and saved the connection and it worked. This was in a 12.04 virtualbox VM.

share|improve this answer
  1. Have your service provider send you a zip with your configuration files.
  2. Select Import.
  3. Make sure these fields are populated:

    • User Certificate
    • CA certificate
    • Private Key

Your Save button will work then.

share|improve this answer

When creating a VPN connection you have to fill out all the required fields before 'save' becomes active. Ensure that you have them all filled out accurately.

share|improve this answer
    
I am very certain the fields are filled out correctly, though I can look to be sure. –  Solignis Oct 21 '11 at 19:03
    
I can understand this being true before 'save' becomes active, but before 'Available to all users' becomes active? –  Jayen Aug 2 '12 at 7:06

protected by Community Dec 10 '12 at 15:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.