Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We know you can either click on the show desktop icon or use CTRL+ALT+D to ask Ubuntu to show the desktop. Unfortunately, this does not always show the desktop in one action.

Sometime, and this is true for at least the last 4 version of the OS, it brings up first to the front all the windows, THEN, with a second click, show you the desktop.

This is very annoying, as when you show the desktop it generally to quickly click on a shortcut.

To understand what I'm talking about, open 7 windows, minimize some, bring some to the front, maximize one, then show the desktop. Then do that on Windows. You'll see the difference.

share|improve this question

closed as off topic by belacq, Jacob Johan Edwards, fossfreedom May 18 '12 at 20:01

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

4  
If the show desktop is not working correctly for you, then you need to file a bug report. FYI, following the steps you describe above on Maverick alpha, the desktop is show almost instantaneously, without fail. –  Stephen Aug 3 '10 at 9:08
2  
This is unreproducible. –  Nathan Osman Aug 3 '10 at 19:54
2  
It is perfectly reproducible. Just open a bunch of windows, minimize some and have one maximized. If you then try to show the desktop, it first unminimizes all Windows, and then if you click again, it'll minimize them. –  Tommy Brunn Aug 5 '10 at 7:08
2  
Why minimize everything? Use ctrl+alt+left/right to switch to a new desktop :) –  invert Aug 5 '10 at 11:43
3  
Why is it downvoted while it's clearly an ubuntu bug ? –  e-satis Oct 15 '10 at 11:09

3 Answers 3

up vote 6 down vote accepted

There seems to be a problem when compiz ("desktop effects") is enabled: https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/236376

I'm afraid for now the only workaround is to disable all desktop effects.

share|improve this answer
2  
Indeed, tested and that's the problem. –  e-satis Aug 5 '10 at 13:02

On my system I use compiz to show desktop. I install simple compizconfig and open the last tab called "edges", I choose one edge and tell it to show my desktop. So when I move the mouse to that edge, it either hide all apps (screenlets included) or show them all.

share|improve this answer
    
Yes, but it does exactly the same thing with the same problem. -1 –  e-satis Aug 5 '10 at 13:12

if u r using gnome-shell i installed a gnome-shell extension comes with a icon on the panel toggles shows desktop :

use this link to install : https://extensions.gnome.org/extension/64/show-desktop-button/

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.