Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with my usb wireless stick (TP-LINK TL-WN821N) when I'm surfing on the net or something like that, so in every ~30 minutes I get disconnected from the internet, unfortunatly whent it happens I always have to unplug and then connect this usb device so that I can connect to the internet again. This is very frustrating :(

If you have any idea please help me!

Thanks in advance!

Attila

ps: under windows it works properly and under the previous version of ubuntu

share|improve this question

5 Answers 5

I suggest you to do the trick proposed in the comment 13 of this Launchpad bug, that is to blacklist the ar9170usb driver:

https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.32/+bug/495562

share|improve this answer
    
yes i did the same ..blacklist the driver and it worked properly –  One Zero Jan 25 '12 at 15:35

This seems to be a driver bug. See the official documentation for that card:

And the bug reports in launchpad:

Some fixes / workarounds are described. Disabling the N-thingy seemed to work accoding to this answer:

share|improve this answer

Same problem here:

uname -r
3.0.0-15-generic

Tried to blacklist the driver ar910usb (which is not directly used by my wireless card).

ar9170usb

So I enabled Backports and updated the system. But still nothing got working. So I made a little google search. Sometimes the N mode is a problem so i created a new file in /etc/modprobe.d/_wlan-conf with these options:

options iwlagn 11n_disable=1

But still the problem exists. Dmesg says nothing about the loss of connection. Also looks like it is easy to reproduce this bug by downloading a big file from FTP/HTTP. Maybe a NetworkManager bug? Any hint?

share|improve this answer
    
Yes, looks like it is a Driver Bug: everytime Network-Manager or Wicd tries to SCAN while transferring data the connection gets lost! –  Otacon Jan 25 '12 at 15:24

Ok i "solved" the problem by manually configuring wireless! HOW TO: 1) Make a config file like this:

ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="Your_neworkName"
        psk="Password"
        key_mgmt=WPA-PSK
        proto=WPA2
        pairwise=CCMP TKIP
        group=CCMP TKIP
}

see this for more details how to. And save it to /etc/wpa_supplicant/wpa_conf.conf 2) Disable your network manager:

sudo /etc/init.d/NetworkManager stop

then test your configuration by running:

sudo wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_conf.conf

Is everything working? Nice go ahead to step 3)

3) Make a new script on your desktop called connect.sh containing

/etc/init.d/NetworkManager stop
ifconfig wlan0 down
dhclient -r wlan0
wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_conf.conf
dhclient wlan0

and assure it is runnable.

4) Install "alacarte" (if Ubuntu 11.10) and create a new Launcher in Network Menu:

  • Name: Connnect
  • Command: gksudo /path/to/your/script.sh
  • Description and icon: everything you like.

5)Search for "Connect" on your Dash and drag and drop it to your Dock ;)

6)Everytime you need to connect to your network just launch "Connect app" and it's done.

N.B. You need to configure every wireless network by hand!!! Please contact me if something doesn't work!

share|improve this answer

I had exactly the same problem with my stick (TP-LINK TL-WN821N V3). After downloading latest network drivers by following this blog entry, it works a lot better:

http://whilesurfing.blogspot.com/2012/02/ubuntu-tp-link-tl821nv3-tl822n-v20.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.