Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set global proxy settings via

System Settings>Network>Network proxy

I set the Socks host. All apps, including the command line apps successfully picked it up. But its a problem with Mercurial, which has trouble finding a PC on the same network. How do I set the system proxy settings to exempt local addresses?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

in the configuration window you mentioned there is a tab like "ignored Computers" (In my german ubuntu it is: "Ignorierte Rechner"). There you can setup rules for connections which do not need to be forwarded to the proxy. You could e.g. add:

192.168.*.*

to this list, depending on which room is "local" for you.

edit: I mean this settings page:

enter image description here

share|improve this answer
    
Hmm I see only host-address pairs for HTTP Proxy,HTTPS Proxy,FTP Proxy and SOCKS host, with an "Apply system wide". Greetings from India, Jesvin :-) –  aitchnyu Oct 21 '11 at 17:32
    
I added a picture of the dialog box I meant... –  Michael K Oct 24 '11 at 5:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.