Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently downloaded 11.10 and demoed on the Live CD. Snapping worked great.

After installing snapping no longer works. I tried recreating my home directory from /etc/skel as well as creating a new user to make sure it wasn't a local problem. No luck. I also tried reinstalling which didn't help. Nor did installing all compiz-plugins* and wmctrl packages and reloading Compiz.

Edit - 1: I installed CompizConfig Settings Manager but nothing jumped out at me to change.

What might have changed between the LiveCD and the installation?

Edit - 2: After continuing to look for a solution I've realized my terms don't mean what I meant them to. By snapping I mean the feature termed Aerosnap in MS Windows where dragging a window to the left/right/top of desktop will cause the window to be sized to fill the left half/right half/all of the screen.

Edit:This install is running on a Dell E6420 with a nVidia Corporation GF108 [Quadro NVS 4200M] Video card. I am selecting "Ubuntu" on the login screen but end up with unity-2d-panel and unity-2d-launcher processes running upon login.

share|improve this question
    
Did you have a look at CompizConfig Settings Manager (ccsm)? –  joschi Oct 21 '11 at 14:21
    
Thank-you for asking. I've updated the question to contain more info. –  Dave Oct 21 '11 at 21:10
    
So the 'grid' effect in ccsm is still activated? Like asked before... you're computer isn't running Unity 2D as fallback? –  joschi Oct 21 '11 at 21:57
    
Yes, 'grid' is activated in ccsm. –  Dave Oct 21 '11 at 22:37
add comment

1 Answer 1

up vote 3 down vote accepted

After learning that Ubuntu was running Unity 2D I started suspecting that there was a problem with my video drivers.

I purged nvidia-current* and nvidia-settings* packages and rebooted (turns out logging off and on again is all that is necessary).

Logging in again the "aerosnapping" now works so I'd consider this answered.

Now to figure out how to get these drivers correctly installed.


share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.