Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 on my home desktop and am having problems with the wireless network. It actually makes the connection, but it is so slow and unresponsive it is unusable.

My wireless network adapter is a D-Link DWL-G520 rev. B with an Atheros chipset, and this is the relevant output from running lspci.

$ sudo lspci -vvv
04:02.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)
    Subsystem: D-Link System Inc AirPlus DWL-G520 Wireless PCI Adapter (rev. B)
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 18
    Region 0: Memory at e3000000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: ath5k
    Kernel modules: ath5k

What other information could help finding the root issue? What logs should I check?


The network is working fine now. Not sure what did the trick, if some fiddling with the router or upgrading network-manager

share|improve this question
up vote 0 down vote accepted

I doubt it's an issue with linux or the ath5k driver(it's a really mature driver). Distance between you and the AP and Tx/Rx power are where I would look.

share|improve this answer
I thought that as well but it's not that far apart from the AP, and I have no problems at all under Windows 7. Unless the driver under Ubuntu doesn't work as well, in which case I would have to move my desktop to test it. – Pharod Oct 21 '11 at 13:15
I don't mean move it closer. In some instances you can need it to be further away. The Tx/Rx power issue. If it's too "loud" some APs turn down their sensitivity. – RobotHumans Oct 22 '11 at 0:41

sudo apt-get dist-upgrade -y

Seems to ease the stress of slow and unresponsive WIFI network for me but not a final solution

share|improve this answer
I'll try it out, but as there is barely a connection, I'm not sure how it will take. Also, not sure about using the -y option, I prefer to check before saying yes :) – Pharod Oct 21 '11 at 17:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.