Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I tried to install Ubuntu 11.10 on a windows 7 machine. The installation froze twice right after the initial purple ubuntu splash screen and after the progress bar stoped responding (no cd or hdd activity for more than 20 minutes). Both times when I tried to reboot my computer back to windows 7 the computer restarted by itself right after loging in to windows giving me a "Systemboot fail or POST interrupted...." message. After pressing F1 to coninue the machine booted just fine to windows. I didnt gine any attention to this problem since it only happened 2 times and right after the failed ubuntu install. After that I installed some other linux distro. So now every time i boot in linux and try to reboot to windows 7 I get an extra reboot at login. Tried to repair windows startup but nothing happened. Also tried to look for blue screens before the restart but none is recorded. Any ideas ?

share|improve this question

closed as off topic by fossfreedom Mar 20 '12 at 20:36

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
"After that I installed some other linux distro. So now every time i boot in linux and try to reboot to windows 7 I get an extra reboot at login" - thus the OP is not using Ubuntu. This is therefore off-topic. However, it would be on-topic at the Unix & Linux Stack Exchange. –  fossfreedom Mar 20 '12 at 20:36
add comment

4 Answers 4

Download GParted partition manager from Ubuntu software center. Find the partition that windows is installed on (probably dev/sda1). It may show you exclamation mark. Right click on it and click "manage flags". Check "boot". Restart your computer with Windows 7 DVD is mounted. Click to repair, and let the installer fix your Windows 7 boot. Then the installer will say you the problem is repaired. Restart your computer and select Windows 7. That's all.

share|improve this answer
add comment

There are two ways I would attempt to handle this.

First, I'd try boot repair as outlined in the Ubuntu wiki:

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

after boot repair, I'd then just boot from live cd again & choose repair existing system.

Then next way I'd resolve is to boot ot Windows & delete the partition that Ubuntu tried to make. Take care that it is not any partition that is being used by Windows else you will encounter more serious issues. After I successfully deleted that partition, I'd start over with the installation process. Before installing, check the disk integrity via md5sum

https://help.ubuntu.com/community/HowToMD5SUM

for errors or simply download & burn a new installation CD.

share|improve this answer
    
i doubt it is a startup problem since windows starts normally after shut down. The partition created by ubuntu is totally deleted and recreated by the tools provided by the other distro. –  on4c1d Oct 21 '11 at 15:11
add comment

this is my fstab

# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
tmpfs           /tmp    tmpfs   nodev,nosuid    0       0
/dev/sda2 /boot ext3 defaults 0 1
/dev/sda3 swap swap defaults 0 0
/dev/sda4 / ext3 defaults,user_xattr 0 1

so i guess the windows partition does not get mounted

share|improve this answer
add comment

maybe it works if you shutdown Linux and boot Windows from a cold start.

It also might help, not to mount windows partitions in linux, if you do not need them. You can remove them from

/etc/fstab

if they are in there and you do not need them.

It als might help to add more information about your system into your question. Especially interesting is, whether there is any information on what is going wron in windows (blue screen???)?

Greetings from Switzerland, Michael

share|improve this answer
    
Thanx for the fast response. Yes, this is how it works. I shut down after using linux and turn it back on to use windows. In that case it does not restart. Will definatelly try to not mount the windows partition. Dont think I need it there. About blue screens... I downloaded BlueScreen Viewer. It has not saved ANY info on blue screens. System Info: Intel core 2 Duo 6400 Asus striker extreme gigabyte gtx 460 8gb DDR2 Windows and linux are on the same HDD and in different partitions. NTFS for windows, ext3 for linux, and a small swap partiotion which i set through the linux installation –  on4c1d Oct 21 '11 at 12:07
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.