Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm giving KDE another try - so far so good. I installed everything using apt-get install kubuntu-desktop. During the installation it asked me which login manager to use and I chose LightDM - however, now I'm finding user sessions (KDE) are behaving a little funny - when left for some time, they lock out asking for password, but there's no way to switch user (i.e. there's a small window asking for password with Ok and Cancel buttons - no Switch User, Shutdown, Suspend or anything).

Pressing Ctrl-Alt-F[something] shows a text log, where I can see a message "Not starting KDM because it's not the default manager" - so I think my problem can be fixed by making it default.

How can I do this?

(actually, trying to switch user via K-menu - Leave - Switch user results in the same dialog: "The session was locked by sergey, please enter your password")

share|improve this question

3 Answers 3

up vote 15 down vote accepted

Reconfiguring

With the Debian and the Debian based (K/X/L/ubuntu) you could use the dpkg-reconfigure.

    man dpkg-reconfigure:

    NAME
           dpkg-reconfigure - reconfigure an already installed package

    SYNOPSIS
            dpkg-reconfigure [options] packages

    DESCRIPTION
    dpkg-reconfigure reconfigures packages after they have already been 
    installed. Pass it the names of a package or packages to reconfigure. 
    It will ask configuration questions, much like when the package was first installed...

That is:

sudo dpkg-reconfigure kdm

or

sudo dpkg-reconfigure gdm

or ...

Kubuntu & LightDM

The LightDM is : https://wiki.kubuntu.org/LightDM

There was a plan: https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-kubuntu-lightdm

QLightDM: https://lists.ubuntu.com/archives/kubuntu-devel/2011-June/005248.html

With the Oneiric the Kubuntu desktop is depending the KDM: http://packages.ubuntu.com/oneiric/kubuntu-desktop

share|improve this answer
1  
Note that when you run the reconfigure command on either gdm or kdm, you have to choose between the two display managers yourself. –  Thomas W. Oct 21 '11 at 18:19

Solution that doesn't require root access

Make a file ~/.xinitrc:

# makes a kde a default desktop after `startx':
exec startkde

Also make ~/.xsession:

# makes a kde a default desktop after `xdm':
exec startkde
share|improve this answer
    
Have been looking for this solution since yesterday. I am not sure what I do, my startx always bring me to WindowMaker. Now I am returning back to KDE ;) –  swdev Feb 19 at 13:21

please have a look at the following file:

 /etc/X11/default-display-manager

There you can change to kdm.

share|improve this answer
1  
This is also a valid answer although dpkg-reconfigure is probably more foolproof. –  Sergey Oct 21 '11 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.