Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on a Lenovo T400 laptop.

In the past I had suspend problems on every second version of Ubuntu (at least it feels like it), but in 11.04 it was working perfectly. Now, after the upgrade to 11.10 closing the laptop lid does no longer initialize suspension.

When I choose 'Suspend' from the shutdown menu it works perfectly, so this does not seem to be an issue with suspend itself.

The options in System Settings>Power are of course set to suspend in case of closing the lid (both for battery and AC poer).

Note: I have no idea if this is of any importance, but I'm running the gnome-session-fallback stuff, as I just hate the Unity desgin.

share|improve this question

4 Answers 4

Lid Close Action

To set up the Laptop Lid Close Action you have to install Advanced Setting (or the Gnome Tweak Tool). It is in the USC (Ubuntu Software Center) under either tweak or Advanced Settings. If installed press the super button and type in tweak or advanced and choose the Advanced Settings. When it opens choose the shell tab;

Advanced Settings Before

Press the arrows and choose you desired on both on AC and on battery;

Advanced Setting After

Default buttons behavior

Install dconf-tools:

sudo apt-get install dconf-tools

Press alt+f2 and open dconf-editor (or in a terminal type dconf-editor)

Navigate to org.gnome.settings-daemon.plugins.power and set your default button-power action there:

enter image description here

On some systems you will also need to mark the item suppress-logout-restart-shutdown.

share|improve this answer
    
I have the same problem as the OP and I followed your instructions, but the values that dconf-edior is showing are exactly what I want... but it still doesn't work... It seems like Ubuntu just ignores these settings... :( –  hage Oct 22 '11 at 10:20
    
Same thing for me: the settings have the same values I assigned them using the GUI, i.e. what I want them to be. But somehow they are not used as they should... –  fgysin Oct 25 '11 at 8:15
    
Updated answer, have a look –  Bruno Pereira Oct 25 '11 at 8:53

I think this is bug https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/863834

share|improve this answer
    
An important comment on this bug report: bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/… –  brandizzi May 12 '12 at 11:14

I'm having the same problem. this might relate to the gnome 3 power mgmt politics.

http://blogs.gnome.org/hughsie/2011/02/02/is-gnome-3-going-to-melt-your-laptop/

I'm using an external monitor so this might be the case. I just switched from closing lid to the keyboard power-down button.

share|improve this answer

This problem exists on 11.10 and later when an external monitor is plugged in to the laptop, as has been noted by others. An excellent workaround is to be found at comment #30 of https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/863834

share|improve this answer

protected by Community Nov 17 '11 at 15:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.