Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the problem that when I open some programs/documents in Gnome, the wrong application is launched to open these.

I think I already narrowed the problem, that everything that is called with file:// will be launched with the wrong program (in my case keepassx). I remember that when everything starts, I wanted to start keepassx from my gnome-panel. Ubuntu asked me with what program it should be started. I wondered a little, since I used it already a lot, so I choosed keepassx from the list. But it seems that this has overriden the file-protocol handler.

Some situations where the wrong program is called: shortcuts in my gnome panel (personal folder - which should open nautilus, keepassx, some txt files), synapse (launcher like gnome-do) and firefox finished downloads.

How can I reset this setting to get everything back to normal?


The only reliable way to open files currently is via nautilus.

To give an example, a shortcut in the gnome-panel has the following properties: Name: myfile.txt, Location: file:///home/dag/myfile.txt, Comment: »/home/dag/myfile.txt« öffnen

I use Ubuntu 11.04 with "Gnome-classic" aka Gnome2 2.32.1

share|improve this question
up vote 3 down vote accepted

There are a few places I can think of looking. I'm not entirely sure how you got in this situation, so I'm not sure which is likeliest:

  1. ~/.local/share/applications/defaults.list (see if you have anything suspicious in there)
  2. ~/.local/share/applications/mimeapps.list (likewise)
  3. Run gconf-editor, navigate to /desktop/gnome/url-handlers, and see if you have a file subdirectory in there.

Do any of those help?

share|improve this answer
Hi, thanks. The mimeapps.list shows an suspicious entry for exo-file-manager from xfce4 (which is installed for another user!): x-scheme-handler/file=exo-file-manager.desktop x-scheme-handler/trash=exo-file-manager.desktop I found out that my question is also a duplicate to this issue: (…) Somehow this helped me (didn't tried xfce since then): (…) – Dag Nov 7 '11 at 8:25

The easiest solution is right click to the file/properties/open with (tab) and select the program you want to use. Maybe you can try too with Ubuntu Tweak to manage the file associations.

share|improve this answer
I can't choose the program when having the shortcut in the gnome-panel, synapse or the firefox downloads. I tried Ubuntu tweak, but the file associations are all correct. In fact the only way currently working to open something is via nautilus. – Dag Nov 2 '11 at 15:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.