Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgraded to 11.10 and there is one pretty annoying thing: whenever Unity decides that my laptop was idle for too long, the screen goes black and -- the most annoying part -- locks up.

Thus, two questions: how do I configure this "idle" period and how do I prevent the screen from locking up in this case?

Thank you.

share|improve this question

3 Answers 3

up vote 5 down vote accepted

The easiest way to do this is open up the System Settings, Dash -> System Settings and select your screen.

You should be prompted with the following screen options;

Screen Options

You simply need to choose a setting that suits your needs - if you do not want the screen to turn off simply select 'Never'

Selection Options

You can also choose whether you want to 'Lock' the screen as well. Once done choose 'All Settings' and then close - you may have to log out and back in again for the changes to take effect.


Update

For 12.04 this setting screen has been renamed to Brightness and Lock - see below;

12.04 setting screen

share|improve this answer
    
Hmm, I can't find this settings Dialog in my System settings dashboard. The closest one I can find is "Display and Monitor" and is looks totally different from yours. Am I doing something wrong? screenshot –  Maxim Sloyko Oct 21 '11 at 9:59
    
Oooh, I just found out what is wrong: I was launching system settings from the "Dash home" menu via search. If you launch the "System settings" from the top right corner dialog, It is totally different and it does have the "Screen" settings you are talking about! –  Maxim Sloyko Oct 21 '11 at 10:03
    
I get to the same 'System Settings' either way via the Dash or the Cog..... –  Mark Rooney Oct 21 '11 at 10:08
    
Well, it turns out, I can to it either way too. It is just that somehow I ended up with TWO different "System settings", when I try to get to them via dashboard. They have the same icons, but, apparently, launch different programs. From this point it is trivial: I just have to remember the order in which they show up in search. –  Maxim Sloyko Oct 21 '11 at 13:13
    
@Maxim - if this fixed your problem accept the answer and upvote it ;-) –  Mark Rooney Oct 21 '11 at 21:55

I believe that if you go in your system settings and then the power options, you will be able to set if you want your screen to lock or not, and after what time.

share|improve this answer

Similar results can be achieved by going to the top of the screen, then select System -> Preferences -> Screen saver.

I did this on my Ubuntu 10.04 system

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.