Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've gotten the desktop cube and rotate cube effects to work. (And it works perfectly when I use the mouse). Unfortunately, it's a little messed up when I use the keyboard (Left/Right).

It switches fine, but when it gets to the new face of the cube then the windows of the cube I just left flash onto the screen for a second. (Example: I currently have a chromium window opened. When I press Right then the cube rotates as it should. When it gets to the new side the chromium window 'flashes' for a moment--even though it's on the other side of the cube.)

Also, (and this is mostly what I want to fix), when I use Right/Left (it should 'rotate Right/Left with window') the awesome animation of the window 'bending' around the cube occurs, but when it gets to the new side it 'flashes' and doesn't come back. It's still on the original cube face.

Sorry for my lengthy description... any ideas?

Edit: Forgot to say: I did this on my laptop running ubuntu 11.10. Thought it might have been just a laptop thing, but I installed ubuntu 11.10 on my desktop today and it did the same thing.

share|improve this question

closed as off-topic by Luis Alvarado Jul 25 at 2:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

3  
I can confirm that bug. It occurs on my machine on every cube rotation event. It is really annoying bug! I tried with fglrx and radeon, both the same problem. The original bugreport is to be find here: bugs.launchpad.net/ubuntu/+source/compiz/+bug/876198 –  user5950 Nov 8 '11 at 1:23

2 Answers 2

up vote 4 down vote accepted

The move to other cube face - causes a "flash" is registered as a bug at Ubuntu's launchpad: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/874862

You can subscribe - to get mails on the subject, including when the bug will be fixed, at the above link. As for the "move window to other cube face" - which doesn't move the window - looking for a solution to that myself - a really useful feature.

share|improve this answer

Though this bug haven't yet been solved for 12.04 LTS, there exist a hack described here: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/862430/comments/194

Go to the mentioned PPA (don't add it!), use 'View package details' link, expand the 'Source' to show all available packages and download compiz-plugins_... package for your architecture. Do not install it, open it with any archive manager instead and extract only one file /usr/lib/compiz/libcube.so from it and put this file into ~/.compiz-1/plugins (create this folder if it isn't exist). Then reboot your system and observe the famous cube without window flashes. Tested in Ubuntu 12.04.2, GNOME Classic and Compiz 0.9.7.12-0ubuntu2. Kudos to the guys who made it possible.

P.S. You can also fix the movement of the windows to another cube face with shortcuts, take a look at my post here: http://askubuntu.com/a/344541. If cube plugin activation crashes your Compiz, you can activate it in config file, this method is also described in this post.

share|improve this answer
    
Has this been corrected for versions newer than 12.04? like 13.04, 13.10 or 14.04? –  udiboy1209 Apr 9 at 14:19
    
If I understand correctly, this was fixed in Compiz 0.9.8.0, which is used in Quantal (i.e. since 12.10 Cube should be OK). I'm using 12.04, so I cannot validate this. 12.04 LTS uses 0.9.7.X branch of Compiz, current version is 0.9.7.12 and in bugreport version 0.9.7.14 is mentioned as a milestone for bugfix. Still waiting... –  whtyger Apr 10 at 15:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.