Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded from 11.04 to 11.10, and I'm noticing a strange window behaviour that I can't seem to fix. Basically it seems like all windows have focus, as shown in this screenshot:

screenshot

It happens almost all the time, but sometimes windows appear as out of focus, and when they are clicked, they stay like that. I tried using GNOME Shell and the problem doesn't exist, so it seems it has something to do with Unity.

Let me know if you need any more info to help me solve this problem. Thanks!

share|improve this question
    
Thanks for the edits! –  Pharod Oct 21 '11 at 17:51
    
Is this a common bug? It is extremely annoying, but I see a very little number of complaints. Does it reveal in only some configurations? –  jesusiniesta Dec 29 '11 at 23:37

4 Answers 4

up vote 2 down vote accepted

Update:

According to Launchpad bug #770283, this is now fixed in Ubuntu 12.04 with the latest updates. I've not personally tested it, as I'm now using the open-source drivers, but from what I've read, it fixes the problem.

Original answer:

Sadly, there doesn't seem to be a fix yet. There is a bug report for Compiz (the window manager running Unity), but no developers have responded. See Launchpad Bug #856138

I suggest logging in or registering on Launchpad and marking the bug as "Affects me too" (you can also do it by clicking this link)

Do you have an ATI graphics card? My laptop with an ATI Mobility Radeon HD 4500 Series graphics card has this same issue on 11.10 and 11.04. However, my NVidia desktop did not experience this glitch, so I'm thinking ATI's driver may be part of the problem.

share|improve this answer
    
Cool, I didn't know you could link to whether or not a bug affects you. Very useful! –  WarriorIng64 Oct 21 '11 at 5:23
    
Yes I have a Lenovo T500 with an ATI Mobility Radeon HD 3650. I didn't have this problem in 11.04, and I just installed 11.10 on my desktop (NVidia) and the behaviour isn't happening, so you may be right. –  Pharod Oct 21 '11 at 12:00

I have same problems with fglrx and 11.10, and solved enabling again the unity switcher functionality (in compiz>unity). I disabled unity switcher to use classic compiz switcher and it started to fail.

share|improve this answer
    
I've had the Unity switcher enabled all this time, and the window decorations (titlebar, close/minimize/maximize, etc) still freeze up. Are there any other changes you made? What graphics card do you have? –  Shane Feb 7 '12 at 2:36

Seems to be a driver problem (fglrx). A temporary solution might be revert back to the radeon driver. I was able to solve it that way.

share|improve this answer

This may be a conflict between Compiz' Viewport Switcher and Unity's default switcher... I disabled the Viewport Switcher in CompizConfig and the problem was resolved.

share|improve this answer
1  
I tried disabling the Compiz Viewport Switcher, and still have the same problem. What graphics card is in your computer? (I'm curious if it depends upon the graphics card as to what breaks and what works...) –  Shane Feb 7 '12 at 2:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.