Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to play a DVD I recently bought, but when I try to, sometimes a message appears:

Could not read DVD. This may be because the DVD is encrypted and a DVD decryption library is not installed.

However I've cheked the ubuntu documentation and installed the libdvdread4 libdvdnav4 gstreamerx.xx-plugins-ugly and bad.

share|improve this question
    
Have u tried VLC? it works for me so well! :) or check the ubuntu restricted extra packages. –  Manuel Andrés Vélez Oct 25 '11 at 17:24
add comment

1 Answer

up vote 4 down vote accepted

Playing Encrypted DVDs

To play encrypted DVDs, the libdvdcss2 package is essential. libdvdcss is a simple library designed for accessing DVDs like a block device without having to bother about the decryption.

Below are the instructions for installing the packages using the command line.

With the entire Medibuntu repository

Adding the repository

The following bash command adds Medibuntu's repository to Ubuntu. It also adds Medibuntu's GPG key to your keyring, which is needed to authenticate the Medibuntu packages.

This command should be run in the Terminal :

sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

If you have added the entire Medibuntu repository, you just need to install the package using APT:

sudo apt-get install libdvdcss2

With individual packages

If you wish to install just libdvdcss2, you can first download the individual package and then install the package.

i386:

wget -c http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.9-2medibuntu4_i386.deb
sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_i386.deb

amd64:

wget -c http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.9-2medibuntu4_amd64.deb
sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_amd64.deb

Source How to add a mediubuntu repository

share|improve this answer
    
I tried this but to no avail! :( –  drN Mar 30 '12 at 22:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.