Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't enable the sound os HDMI in Maverick with a ECS GT240. Why this not work "out of the box"?

share|improve this question
add comment

2 Answers 2

Open the Sound dropdown (from the panel), select Sound Preferences..., click the Output tab, and select the radio button next to the HDMI Audio out device you require audio out on.

However if your HDMI device is not listed then the device is not properly installed or acknowledged by the sound server.

share|improve this answer
1  
And, in many cases, the latter means you have to upgrade to the latest version of the ALSA drivers (involves doing your own kernel module compilation). –  Chris Jester-Young Oct 14 '10 at 2:25
    
Don't work. I've try all sugestions in ubuntu forum and until now no sound in the TV speaker. –  Sergio Oct 23 '10 at 21:19
    
When I open sound preferences and go to the output tab, I only get "Analog stereo internal audio". I've started a 100 reputation bounty for a quick howto to make the device (video card? sound card?) appear in the list. The video card is an Nvidia GeForce 8600M GS, by the way. –  Bou Nov 11 '10 at 14:01
add comment

first check if there is any HDMI device listed after using:

aplay -l

if there is anything with "HDMI" select Sound Preferences -> the Hardware and from the list below you must select something like "Digital Stereo HDMI output" and it should work.

If that didn't help and you have nvidia GPU then this should help you : http://forum.xbmc.org/showthread.php?t=69479

share|improve this answer
    
Hi Tomasz, I followed the instructions in that forum but adding 'alias snd-card-0 snd-hda-codec-nvhdmi' at the end of /etc/modprobe.d/alsa-base.conf didn't make my nvidia card appear when I launch 'aplay -l', or on the sound preferences, and the sound still comes out through the laptop's speakers. –  Bou Nov 11 '10 at 15:11
    
By the way, there seems to be a "digital stereo duplex" item in the sound preferences (i.imgur.com/XoP63.png) but choosing that results in no sound, as opposed to hdmi out. Not sure if those could be related. –  Bou Nov 11 '10 at 15:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.