Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently changed my OS from Ubuntu 11.04 to Kubuntu 10.04 but don't know how to get my executable bash scripts to run on Kubuntu. On Ubuntu all I did was click on the text file and I was given the options to run, run in terminal, display etc. but when I click on the file in Kate on Kubuntu these options don't appear. Permissions on the file are set to executable, but how do I get the script to actually execute? Typical contents of the files are

#!/bin/bash
's/^\(.\{4\}\)\(.\{2\}\)/\1,\2,/g' ~/Documents/DataOnly/AD70000$.TXT > ~/Documents/octave/auscad
exit 
share|improve this question
    
What happens if you click on it? I believe that KDE will open the script without asking if the file is set to executable. Do you get a text editor instead? –  Bruno Pereira Oct 21 '11 at 0:49
    
A left mouse click opens the file, a right click gives a dialogue box with options to cut, copy, rename, move to waste, open with, actions, compress and properties. Open with gives the options of Kate or Open Office, actions leads to preview or create project with K3b, compress gives options for zip, rar etc. Nowhere is there an option to run. –  babelproofreader Oct 21 '11 at 1:00
    
Duh! Stupid me. The window decoration style I have opted for made the radio style button to toggle between executable/non-executable difficult to see what option is selected. Problem now solved. –  babelproofreader Oct 21 '11 at 1:23
3  
@babelproofreader Preferably you should post that as an answer and accept it. –  WarriorIng64 Oct 21 '11 at 1:29

2 Answers 2

Originally posted by babelproofreader:

Duh! Stupid me. The window decoration style I have opted for made the radio style button to toggle between executable/non-executable difficult to see what option is selected. Problem now solved.

share|improve this answer
    
I'm posting the answer given in the comments so that this question will no longer show up as unanswered. –  Scott Severance Dec 18 '11 at 13:05
chmod +x [script name]
./[script name]
share|improve this answer
4  
It would be more helpful if you would add a bit more information on what those commands do. –  Octavian Damiean Feb 6 '12 at 21:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.