Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 with Wubi and I am currently on a campus that requires the usage of a proxy server. I went into System Settings/Network/Proxy Settings. Didn't work. I manually set the proxy in Firefox and I do have access to the internet; however, I cannot add apps or update Ubuntu. How can I fix it? Thanks

share|improve this question
add comment

8 Answers 8

On my fresh install of Ubuntu 11.10 64bits, this worked for command line with apt and Ubuntu Software Center.

Create the file /etc/apt/apt.conf and put this line with your proxy settings :

Acquire::http::Proxy "http://login:password@yourproxyaddress:port";

example :

Acquire::http::Proxy "http://bob:123bob@bobproxy:8070";
share|improve this answer
3  
put it into a separate file: /etc/apt/apt.conf.d/80proxy because when you get updates, your settings will be overwritten. –  gajdipajti Apr 12 '12 at 15:02
add comment

Two steps are required to get internet fully working in a proxified environment:

Gnome

Provide the proxy URL to the gnome-network-properties:

enter image description here

Shell

Add following to /etc/environment:

ftp_proxy="ftp://username:password@proxy.com:8080/"
http_proxy="http://username:password@proxy.com:8080/"
https_proxy="https://username:password@proxy.com:8080/"

Or

Add following to your .bashrc:

export ftp_proxy="ftp://username:password@proxy.com:8080/"
export http_proxy="http://username:password@proxy.com:8080/"
export https_proxy="https://username:password@proxy.com:8080/"

Please note, however, in case if proxy environment variables are set in .bashrc, commands that are being executed under different user privileges will not have this variables set (sudo will fail, for example). To get past this you might need to modify .bashrc of these users as well. In case of sudo, it is enough to execute it with -i argument, so it will preserve existing environment (sudo -i apt-get update will actually work without modifying root's .bashrc file).

share|improve this answer
add comment

I'm going to presume that your proxy settings are a URL to a server somewhere on campus, which probably means that you are using a PAC script. If your proxy settings do not consist of a URL, ignore this answer.

Firefox should work fine if you set the system proxy settings to this URL and it is set to use system settings.

Alas, the system settings just deliver the script URL to applications querying what the proxy should be - while browsers, and other apps which share browser codebases (like Thunderbird) are quite happy with PAC scripts, most applications are not. This includes many of the core system applications.

If your proxy config is delivered via PAC script, the best thing to do is to download it using your browser, and read through it looking for the actual addresses and ports of your proxy servers. Then use these to populate the manual proxy settings, which should work for more applications.

share|improve this answer
add comment

It may seem strange, but installing Synaptic on 11.10 and configuring the proxy and authentication settings there fixed apt-get as well.

I tried lots of things before that, I set the proxy settings everywhere I could (system settings, /etc/apt.conf, /etc/apt.conf.d/*, gconf-editor, environment variables), but nothing helped - apt-get update still hanged and tcpdump was showing it was trying to directly access 91.189.92.180.80.

Changing the settings with Synaptic fixed that. I actually hate this obscurity, it resembles Windows. However, it worked for me.

share|improve this answer
add comment

I've have the same issue in my campus, but I' have no acces to internet, however you may try to "apply system wide settings" in the same window you configure the proxy.

share|improve this answer
add comment

http://www.ubuntugeek.com/how-to-configure-ubuntu-desktop-to-use-your-proxy-server.html

After a mild bit of googling.

if nothing else works try out the shell commands.

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Mahesh Sep 30 '12 at 5:37
add comment

Try this:

1) Open a terminal:

Alt+F2 and type gnome-terminal

2) Paste the following code to install gconf-editor:

sudo apt-get install gconf-editor

3) Execute gconf-editor:

gconf-editor

4) Walk down the tree to system -> http_proxy

5) Search for use_http_proxy and check it.

6) Try again.

share|improve this answer
1  
That's kinda chicken in an egg problem, since he needs proxy to do that, BTW I have tried all that solutions on the net an I think ubuntu proxy client stopped working with authentication. :( –  danizmax Nov 29 '11 at 6:45
add comment

I have not tested using the "gconfeditor" but every other ways actually failed to work. Then, I found a way which is working but it is very tedious.

1. Install Ubuntu 10.10. Proxy works perfectly with this version.

2. Then upgrade it to upper version.

To do upgrade in a faster way. Download the "alternate iso" for that perticular version and then upgrade the ubuntu by mounting that "iso" file. It will not take much time. After the final upgrade to the desired version, proxy will still work.

If some one found any other way, please post it. Thanks in advance :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.