Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 10.10 and it does not work, it hasn't worked since the beta I believe, any ideas? By the way this is a clean install, and it does not work on my older install either.

share|improve this question

closed as off-topic by Seth Apr 2 at 2:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I can confirm this and found no solution. Shotwell Facebook and Empathy Facebook work fine. In Gwibber no matter what you do (even if successfully authorized) it will not show up in the list of accounts. –  NightwishFan Oct 14 '10 at 1:08

6 Answers 6

up vote 3 down vote accepted

This worked for me, thanks to this user on Ubuntu Forums. http://ubuntuforums.org/showpost.php?p=9980897&postcount=15

Go to your home folder and show hidden files, open .config/gwibber/ and delete gwibber.sqlite.

share|improve this answer
    
That worked! Great thanks! –  TheX Oct 16 '10 at 17:28
    
Thank the user on the forums! :) –  NightwishFan Oct 16 '10 at 20:30
    
Yeah, but I would never have found that, I have been looking for a fix since 10.10 hit the alpha stage... –  TheX Oct 17 '10 at 2:13

As mentioned, this is a bug: https://bugs.edge.launchpad.net/ubuntu/+source/gwibber/+bug/614742

According to a Gwibber developer, the problem actually lays with the Facebook API:

Since Gwibber was included by default in Ubuntu, usage has gone way up and we quickly exceeded our API request allocation with Facebook. Facebook allocations are per application, not per user, which means Facebook blocks API requests for everyone, not just the users which are refreshing too often, etc.

http://blogs.gnome.org/kenvandine/2010/10/19/gwibber-and-facebook-call-for-help/

share|improve this answer

I found that deleting the gwibber.sqlite as suggested didn't work for me. What did was removing :

.gconf/apps/gwibber/preferences/%gconf.xml

This was under the user profile. Soon as I did this it worked find and the size of the newly created xml file jumped up by 6 times the amount.

share|improve this answer

Login to your facebook account and click: Account > Application Settings. Remove the link to gwibber by clicking the X on the right hand side. Go back into gwibber and try adding your account again.

share|improve this answer
    
This does not work for me sadly. :( –  NightwishFan Oct 14 '10 at 5:06
    
Yeah that was one of the first things I tried... –  TheX Oct 14 '10 at 12:23

unfortunately, because of the bug Mike has written about, the only solution that works now is trying to remove/add account many times :(

I tried about 35 times, and finally it worked...

share|improve this answer
1  
Please don't recommend this, part of the problem is there are a bunch of gwibber users and Facebook is throttling the application, so when you do that it keeps triggering the API limits. –  Jorge Castro Oct 14 '10 at 18:25

The latest Gwibber updates fixes the issue. Gwibber showing feeds now. Thought of updating here. :)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.