Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my ubuntu to 11.10 on day one but the unity 3d is not there as an option. I have User Defined, Recovery Mode and Ubuntu 2D.

I've done this test /usr/lib/nux/unity_support_test -p and all results are green YES. Here's the result

OpenGL vendor string:   ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6700 Series 
OpenGL version string:  4.1.11005 Compatibility Profile Context

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
share|improve this question

2 Answers 2

up vote 6 down vote accepted

Clear your apt cache

sudo apt-get clean

Install Ubuntu desktop and force a re-install

sudo apt-get install --reinstall ubuntu-desktop

This will install all the packages necessary from the desktop to run, you should see Ubuntu as an option next time you reboot.

share|improve this answer
    
I honestly didn't expect the solution to be so straight forward and fast as this. Muito obrigado, Bruno! –  Digger Oct 20 '11 at 22:54
    
did it work? :D –  Bruno Pereira Oct 20 '11 at 22:54
    
Like a charm! Thank you a lot! –  Digger Oct 23 '11 at 14:32
    
wlcm, really happy it was that easy ;) –  Bruno Pereira Oct 23 '11 at 14:35

I had a similar problem when running the beta version of 11.10. What I did was go into the software center and search for Unity, uninstall then re install it with all the add-ons listed.

If that doesn't work, try running "sudo apt-get update" and "sudo apt-get upgrade".

share|improve this answer
    
Yeah, brunopererira81's hint worked immediately but I have a hint you're right too.Thanks anyway. –  Digger Oct 23 '11 at 14:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.