Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In 11.10 I replaced my aging Nvidia card with a new Radeon HD 6970 card. The single card has two DVI output ports which I've connected to two monitors. I installed Catalyst version 11.9 and I cannot get multiple monitors set up the way I want. I tried:

$ sudo amdcccle

and setting the mode to single desktop multiple monitors and whenever I do that Unity crashes and I get back to the login screen. Nothing shows up in the Xorg.*.log files for me to post here. There's only one card so I don't think xinerama would be any help here. Anyone have any ideas?

EDIT: Here's my xorg.conf file:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "0-DFP3"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1280x1024"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-CRT1"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1280x1024"
    Option      "TargetRefresh" "75"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option      "Monitor-DFP3" "0-DFP3"
    Option      "Monitor-CRT1" "0-CRT1"
    BusID       "PCI:5:0:0"
EndSection

Section "Device"
    Identifier  "amdcccle-Device[5]-1"
    Driver      "fglrx"
    Option      "Monitor-DFP3" "0-DFP3"
    BusID       "PCI:5:0:0"
    Screen      1
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    DefaultDepth     24
    SubSection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "amdcccle-Screen[5]-1"
    Device     "amdcccle-Device[5]-1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
share|improve this question
    
Care to post some screenshots of your configuration? –  Bruno Pereira Oct 20 '11 at 20:52
    
What would you like me to post? lspci? xorg.conf? –  Mike Axiak Oct 20 '11 at 22:43
    
xorg.conf plz, I already know your card model ;) –  Bruno Pereira Oct 20 '11 at 22:45
    
Posted. Thanks for any help. –  Mike Axiak Oct 20 '11 at 23:00
add comment

3 Answers

I have recently installed Ubuntu 11.10 64bit and used the same guide:

AMD Installing Catalyst Manually Guide

However, had to install ATI Catalyst version 11.11 after removing previous fglrx modules.

After reboot and configure in amdcccle I ran sudo service lightdm restart and logged back in.

Spanning monitors came up in lightdm and carried over into session.

share|improve this answer
add comment

I've finally gotten it to work, and it took more than simply reinstalling Ubuntu, which is why I'm answering my own question. I took the directions from http://wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29

These are my steps, which were important since it turns out that 64-bit breaks down in the latest 11-9 default installation.

  1. Install packages:

    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

    Since I'm on 64-bit, I had to add to that:

    sudo apt-get install ia32-libs

  2. Download the latest Catalyst package:

    cd ~/; mkdir catalyst11.9; cd catalyst11.9
    wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-9-x86.x86_64.run
    or for the new latest
    wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-11-x86.x86_64.run

  3. Create the deb packages

    sh ./ati-driver-installer-11-9-x86.x86_64.run --buildpkg Ubuntu/oneiric

  4. Install the deb packages

    sudo dpkg -i fglrx*.deb

  5. Create basic aticonfig xorg file

    sudo aticonfig --initial -f

  6. Set PCS:

    sudo aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

  7. Restart

  8. Opened amdcccle with sudo and configured to dual screen (proceeded to get kicked out and log back in).

  9. At this point, go to the Displays option in ubuntu (dropdown from top-right screen) and uncheck mirror and set the desktop to span the two monitors.

And now I can finally enjoy OpenCL with two monitors in 11.10 amd64.

share|improve this answer
    
Very useful. I have to do this on Xubuntu too. It really bugs me that Canonical is doing away with ccsm and forcing unity on everyone...Just makes it difficult for the rest of us that want control over our boxes without LFS. –  hbdgaf Dec 3 '11 at 2:06
    
Just an additional note: ccsm still crashed on me with this and failed to keep settings applied. I had to manually edit xorg.conf and enable xinerama, but I'm using 3 screens. –  hbdgaf Dec 6 '11 at 15:21
add comment

I had the same thing, with a Mobility Radeon HD 5000 Series card. Catalyst would close after every 'Apply', without actually doing anything, and if I invoked it via the terminal, no messages would appear to account for the program closing/crashing. After a couple of rounds of restarting, as asked by Catalyst, suddenly the Unity Launcher, Dash and Tray disappeared completely. unity --reset or --reinstall had no effect. I had to reinstall the entire thing.

share|improve this answer
    
So you reinstalled ubuntu entirely to get it working? –  Mike Axiak Oct 21 '11 at 0:24
    
Yeah. Ridiculous, I know. First time in six years of full-time Ubuntu use I've had to do something so drastic. The worst part is that I haven't installed Catalyst yet! I'm using the open source driver, which works pretty well, except for the incredibly annoying sound of the fan going at 100% ALL. THE. TIME. –  Eugenio Perea Oct 21 '11 at 19:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.