Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been looking a lot for this, but I just can't get a global menu to get working on Xubuntu 11.10 64-bit. The best solution I've found is http://www.omgubuntu.co.uk/2011/10/how-to-enable-ubuntus-global-menu-in-xubuntu-11-10/ but it doesn't work: when I add the applet to the xfce panel, it seems to instantly crash. When I run xfce4-panel in the console, the last 3 lines look pretty relevant:

/usr/lib/xfce4-indicator-plugin/xfce4/panel-plugins/xfce4-appmenu-plugin: error while loading shared libraries: libxfce4panel-1.0.so.3: wrong ELF class: ELFCLASS64

xfce4-panel-Message: Plugin indicator-appmenu-29 has been automatically restarted after crash.

/usr/lib/xfce4-indicator-plugin/xfce4/panel-plugins/xfce4-appmenu-plugin: error while loading shared libraries: libxfce4panel-1.0.so.3: wrong ELF class: ELFCLASS64

This might indicate the plugin does not work on my 64bit OS, but I couldn't find a 64-bit alternative...

I would really appreciate if someone could help me a bit further with this. ANY way to get a global menu working will do! I got used to it on my hackintosh, and now I can't live without it. :)

PS: Although I stated [xubuntu] in the title, I actually run the default ubuntu, on top of which I installed xubuntu-desktop. I don't really use Unity anymore since it's too buggy without hardware acceleration.

Thank you in advance for the assistance, any suggestion is appreciated.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Since i don't have an 64bit machine , i only published 32bit packages , please try to compile it from source code:

http://opendesktop.org/content/show.php?content=146102

On this page , i provided source code for downloading , you may need to run:

sudo apt-get build-dep xfce4-indicator-plugin -y

to get all development headers ahead of compilation

share|improve this answer
    
Thanks a lot, building it from source did help!! I got the appmenu working now, however, it seems to be unstable, it crashed after i started gedit: (xfce4-appmenu-plugin:10617): libxfce4panel-CRITICAL **: IA__xfce_panel_plugin_add_action_widget: assertion `GTK_IS_WIDGET (widget)' failed (xfce4-appmenu-plugin:10617): Indicator-Appmenu-CRITICAL **: Unable to claim the name com.canonical.AppMenu.Registrar –  Mr. Pixel Oct 22 '11 at 6:46
    
After a fresh restart the appmenu seems to be working like a charm (I still get the above-mentioned error, but anyway). Thanks a lot for your answer! –  Mr. Pixel Oct 22 '11 at 7:05
    
@Mr.Pixel , have you tried to log out and log in again , It's like some dbus interface wasn't exported yet. I installed gedit through apt-get , and it works smoothly. –  warl0ck Oct 22 '11 at 7:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.