Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm not sure what kind it is, it doesn't use a propriety driver, it runs out of the box. In 10.04 it worked fine, in 10.10 it'll work, but randomly lose connection, though it won't state it, then it'll work again, and then stop working, very on-and-off behavior.

The laptop is an HP Pavilion dv6.

share|improve this question
Can you please run an lshw and add it to your question so we can get more information about your hardware? Thanks! – Jorge Castro Oct 14 '10 at 4:09
up vote 1 down vote accepted

Sounds like a problem I had with my Dell laptop, and according to the HP web site it is mostly a Intel based 802.11 ABGN wireless card which my Dell had.

My Dell laptop had a problem with it losing connection with a wireless access point using 802.11n. This problem is a known issue with the iwlagn driver, and the best workaround is to disable 802.11n on the card. To disable 802.11n on this card create/edit your /etc/modprobe.d/options.conf file:

sudo gedit /etc/modprobe.d/options.conf

And add the following to it:

options iwlagn 11n_disable=1 11n_disable50=1
share|improve this answer
Thank you, I think it worked! – Grayson Oct 15 '10 at 19:22

Alternatively, have you considered using an alternative wifi manager? I myself had some problems with nm-applet, but I installed wicd from the repositories, and the problems just disappeared.

You can get wicd with sudo apt-get install wicd-gtk, and then restart X.

share|improve this answer

It's an outside chance but have you considered whether external factors may have changed? It might be worth rechecking: signal strength; sources of interference; alternative channel number.

share|improve this answer
I've checked, I also have a desktop and netbook, and they function fine – Grayson Oct 14 '10 at 19:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.