Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use plymouth with ubuntu server 11.10 but with no luck. I've installed the server as minimal virtual machine on VirtualBox. Then I installed plymouth theme, but it does not show up. One of the theme I used only displayed a text during the boot. So if anyone get it working, I hope to know how!

share|improve this question

1 Answer 1

plymouth always has a theme and is always used in the boot of Ubuntu, its just not obvious because servers use the details theme which is in the plymouth package itself.

/lib/plymouth
/lib/plymouth/themes
/lib/plymouth/themes/details
/lib/plymouth/themes/details/details.plymouth

Before running down the theme rabbit hole though, make sure you have added quiet back into your grub prompt. By default, servers do not have quiet because administrators want to see the text that commands output as they start up (this was a change made in 11.04). You'll need the tool debconf-utils to check it, then do:

debconf-get-selections | grep grub | grep quiet

If you see noquiet in there, then that may be what is stopping your logo from appearing. Also if you see nomodeset that will stop graphical boot. You can fix this with

sudo dpkg-reconfigure grub-pc

BE CAREFUL as those settings are vital to your system being bootable, so possibly consider doing a backup before changing them.

Now, if you do have quiet mode on, and you want to have another theme chosen, you need only install it, and it should be set as the default. If you'd like to manually check what the default is, you can use the tool update-alternatives

$ update-alternatives --list default.plymouth
/lib/plymouth/themes/default.plymouth
$ update-alternatives --display default.plymouth
default.plymouth - auto mode
  link currently points to /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
/lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth - priority 100
  slave default.plymouth.grub: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.grub
Current 'best' version is '/lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth'.

If you'd like to make the graphical logo appear on your server boot, it should be as easy as doing

sudo apt-get install plymouth-theme-ubuntu-logo

If that doesn't cause the default alternative to change to the output above, then you can always force the issue with:

sudo update-alternatives --config default.plymouth

Though that may just tell you there is only one choice. If you have plymouth-theme-ubuntu-logo installed, and you've removed nomodeset, and you have quiet as a boot option, and you still get no plymouth theme then your graphics hardware may just be incapable of providing a graphical boot for your server. plymouth-theme-ubuntu-text should at least give you the version and loading dots.

share|improve this answer
    
Excellent answer. I was puzzled why the graphical boot won't appear on my minimal installation. It's too bad the OP went MIA without choosing this as solved. –  Oxwivi Sep 14 at 10:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.