Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm unable to run Ubuntu Tweak. It seems to have a problem with Python or something, but I'm not sure.

Here is the output:

/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py:47: RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail.  As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
  warnings.warn(warn_msg, RuntimeWarning)
Gtk-Message: Failed to load module "rgba"
Traceback (most recent call last):
  File "/usr/bin/ubuntu-tweak", line 53, in <module>
    from ubuntutweak.main import UbuntuTweakApp, UbuntuTweakWindow, show_splash
  File "/usr/lib/python2.7/dist-packages/ubuntutweak/main.py", line 31, in <module>
    from ubuntutweak.gui.dialogs import ErrorDialog
  File "/usr/lib/python2.7/dist-packages/ubuntutweak/gui/dialogs.py", line 21, in <module>
    from gi.repository import GObject, Gtk, Gdk, Pango, Vte
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 222, in _load
    version)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 90, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '3.0', but '2.0' is already loaded
share|improve this question
    
Which version of Ubuntu are you using? I don't think Ubuntu Tweak has been updated to work with Ubuntu 11.10 yet, if that is your case. –  WarriorIng64 Oct 20 '11 at 15:42
1  
@WarriorIng64: 0.6, and yes, it's supposed to be updated for 11.10 in the PPA. –  RolandiXor Oct 20 '11 at 15:44

1 Answer 1

up vote 1 down vote accepted

A recent update seems to have fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.