Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded to Ubuntu 11.10 and it seems that it has a lack of support for internet connections with a proxy.

Pidgin has stopped working, and when I go to the Proxy tab, under the settings window, it says that it can't find the proxy configuration program (after explaining that pidgin uses the Gnome preferences). Here I found this bug

Empathy seems that doesn't support proxy neither, as you can see here and here

My last hope was Kopete, but seems that it also hasn't proxy support :(

Any idea on how to use a multi-protocol chat client in Ubuntu 11.10 with proxy support?

share|improve this question
add comment

2 Answers

A friend at work found the solution. In Pidgin, the Proxy tab in settings doesn't work. But if you go to the Accounts window, modify an account and go to the Proxy tab, you'll be able to edit manually the proxy of that account. In my case, setting "Use environmental settings" worked.

share|improve this answer
add comment

Pidgin says that it can't find the proxy configuration app, but it's using the environment variables set by the gnome proxy configuration network app. The problem is that if you set a proxy for SOCKS connection on GNOME's NetworkConfig app, Pidgin will try to connect using SOCKS 5. To resolve this, just unset your SOCKS proxy and Pidgin will use the HTTP proxy. It worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.