Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All of the references I've found for Gnome 3 keyboard shortcuts list that alt+tab switches between applications and alt+` switches between windows (some actually say alt+~, but I think they're mistaken, and I've tried both anyway). Maybe that functionality works for Gnome 3 on Fedora or something, because no matter the key combo I try, nothing will switch between windows except for opening the alt+tab dialog and using arrow keys to navigate it (and at that point it's faster to just use a mouse..).

How do I quickly switch between windows in Gnome 3?

share|improve this question
Have you found a solution? I just started running Gnome3 on Ubuntu 12.4, and now alt-tab behaves identically to tab. – Rob Mar 19 '12 at 18:07
@Rob I've also go this problem on Ubuntu 12.04 where alt + tab does the same as tab. Did you find a fix? – Neil May 10 '12 at 22:20
@Neil - I fixed it, but I've fogotten what I did. I think I futzed around with ccsm and it got better. – Rob May 11 '12 at 13:50

In GNOME Shell, you should be able to switch between multiple windows of the same app by running Alt + the key above tab on your keyboard. For US users, that shortcut is Alt + ` but other keyboard layouts are different.

This is different than Unity in Ubuntu 11.10 which uses Alt + ` for all layouts. (I expect that behavior would improve in Ubuntu 12.04).

share|improve this answer
So if my system DOESN'T do that, then I have a bug, as mentioned in the first paragraph of my post? – Joseph Oct 24 '11 at 14:18
I'm using Gnome 3 with Ubuntu 13.10 and the NEO layout, the mentioned shortcut doesn't work /: – Andy Jan 8 '14 at 10:14

I know this question is old but it was a top result when I searched this problem and there's no solution here.

The solution that I, and I think the OP, was looking for is Super+Tab.

This is the "change applications" action in the keyboard shortcuts.

share|improve this answer

Check the shortcut tab in gnome's keyboard settings.

For me (Ubuntu 13.10), Switch windows of one application is set to Alt+Caps+Tab.

Additionall, there is the Alt+F6 shortcut to immediately switch windows of one application – it only applys to one workspace.

share|improve this answer

Hit alt-tab to get to the app-switching "toast message" (the big balloon with the icon that appears in the middle of your screen).

With alt key down, then hit the arrow keys -> <- to go to the left and right in the app menu. So you need two hands to switch between applications.

On my 13.10, after hitting the left-arrow or right arrow keys once, the alt-tab left-hand-only key-combination continues to work again.

share|improve this answer

In ubuntu 12.04 precise pangolin you go to

CompizConfig Settings Manager > Window Management

and tick "Static Application Switcher"

To install CCSM:

sudo apt-get install compizconfig-settings-manager

Install via the software center

share|improve this answer
This question is about gnome-shell, not Unity. – jokerdino Apr 6 '12 at 14:32
It solved my problem with Ctr+Tab, so I decided to share it. – misza222 Apr 7 '12 at 17:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.